CPU Throttling not running in laptop

Jorge Tomé Hernando jorge at jorgetome.info
Wed Jun 7 11:09:01 BST 2006


Hello all

I am trying to upgrade my laptop from Breezy to Dapper. The process is
being far to be easy. The upgrade using apt did not work, a lot of
problems with dependencies. Trying to do a fresh install with the new
graphical installer also failed, the installer died without any message.
After this I downloaded the  alternative install CD and made a fresh
install formating the hard drive.

The process was without mayor problems but after it i have got an almost
unusable laptop because it works in an extreme slow way. It takes more
than 10 seconds to open a simple terminal, for example.

I have already enable the DMA in all the drivers and also i have installed
the fglrx drivers for the ATI graphic card. But the problem persists.

Now i have found that the CPU throttling is not working. Therefore the CPU
is running allways at the lowest speed available 800 MHz. With Breezy CPU
throttling worked without problems (also in the WinXP partition i am using
in this moment).

I have tested that the problem persists no matter if i use the 386, k7 or
686 kernels (2.6.15-23).

It seems that, for some reason, the CPUFreq driver is not loaded and
therefore the powernowd daemon is not able to manage the CPU Throttling.
Furthermore i have seen that the powernow-k6/7/8 drivers are only
available in the modules directory of the 386 kernel, not in the k7 and
686 kernels.

I have boot using the 386 kernel and i have tried to load manualy
(modprobe) the different CPUFreq drivers: powernow-k8, etc. In some moment
the powernowd daemon was able to load but indeed in that case the
processor was allways running at 800MHz.

The laptop is a HP Compaq nx6125 with an AMD Turion 64 processor.

Can you give me some advice about what more we can try?.

Thank in advance
-- 
Jorge Tomé Hernando
http://www.jorgetome.info
Linux Registered User #362778



More information about the kubuntu-users mailing list