can't start kde, can't start ksmserver

Christopher J. Bottaro cjbottaro at
Tue Jul 4 01:38:37 UTC 2006

I don't think it has to do with permissions, uids or any of the stuff you
mentioned.  Root couldn't even start KDE in single user mode, nor could any
other user (even newly created ones).  I have not change my permissions,
nor I have changed my UID (unless something did it behind my back).  Simply
reinstalling ksmserver (and Kubuntu desktop) fixed my problem which leads
me to believe that some global config got hosed somehow.

Yeah, I'm on my 3rd try of Kubuntu.  I tried Breezy, but a lot of multimedia
stuff didn't work well (lots of crashes).  Then I put Dapper on my laptop,
but had to remove it because of this bug:
Now Dapper is only on my home desktop.  I'd like to try it again on my
laptop now that there are 2 potential solutions to the aforementioned bug,
but installing a distro, then my dev environment at work, is very time
consuming and I can't risk anymore downtime if the solutions don't work. 
Oh well.

I don't want to start a flame war over FC vs. Kununtu.  I *hate* that FC's
default desktop is Gnome.  The only reason I stick with it is because of my
constant success with it since FC2 (on multiple desktop/laptop systems). 
Hopefully I can workout all the kinks in Kubuntu and completely switch to a
KDE based distro.  ..but it's a little scary since most of the bugs I
encounter in Kubuntu are showstoppers (i.e. I cannot do my work) where as
the bugs in FC are just annoyances.

Sure I 'solved' this problem, but I have no idea why it happened in the
first place, and because of that, I don't know if it will reoccur again the
next time I reboot.  :(

Sorry for the rant, please don't take this as an anti Kubuntu post.  I love
my car, but I'll still bitch to the dealer and manufacturer to fix things,
ya know?  :D

-- C

James Gray wrote:

> Hash: SHA1
> Christopher J. Bottaro wrote:
>> Any ideas?  I can't use my computer because of this...
>> I deleted /var/tmp/kdecache-<user> and /tmp/kde-<user>
>> and /tmp/ksocket-<user> as per some instructions on the internet.  I also
>> moved $HOME/.kde to $HOME/.kde.bak.  Nothing has worked.
> I've seen this sort of mess before when a noob decided to change their
> UID and wondered why everything broke.  Here's something else to try:
> - - move $HOME/.Xauthority to $HOME/.Xauthority-old and try again.
> There's a few other hidden files in $HOME that X/KDE use for IPC and
> DCOP so you may need to rename a few others too.
> If all else fails, move your entire $HOME directory to $HOME-old like
> this from a terminal (CTRL+ALT+F1):
> 0. Log in as you (eg "chris").
> 1. sudo -i
> 2. mv /home/chris /home/your-user-OLD
> 3. mkdir /home/your-user
> 4. cp /etc/skel/* /home/chris
> 5. chown -R chris:chris /home/chris
> 6. chmod -R 0775 /home/chris
> 7. CTRL+D (this should drop you back to your normal account)
> Log out then switch back to KDM (ALT+F7) and restart the X server.  Now
> log in as your normal user account via KDM (ie, "chris").  You should be
> up and running again.  If not, see if there's any useful info in
> ~/.xsession-errors
>> To reiterate, when I start KDE, it makes it half way through the splash
>> screen progression, then I get an X dialog saying something about
>> ksmserver
>> can't start, please check my installation.  ksmserver exists and is in my
>> path.
> Sounds like screwed up permissions/ownerships somewhere.
>> Kubuntu is really frustrating me.  I'm trying so hard to use it because
>> it's suppose to be *the* KDE distro, but so far in my experiences, Fedora
>> Core 2-5 + the kde-redhat project has been far superior as a KDE distro.
> Now, now, no need to start a flame war just coz you're having problems.
>  There are MANY good reasons to avoid Fedora (and every other RPM-based
> distro) but that's a whole other holy war ;)
>> Please help me out, I don't want to ditch Kubuntu for a third time...:(
> Yikes - you do this often?  Wow.  I've only ever done this ONCE and I
> knew exactly what I'd changed to made it go "pop". PEBKAC maybe? :P
> Hope this helps :)
> Cheers,
> James
> Version: GnuPG v1.4.3 (Darwin)
> Comment: Using GnuPG with Mozilla -
> 872ylkqQWSZ5J7raK0S2evo=
> =VffZ

More information about the kubuntu-users mailing list