FGLRX and ATI

Harry Vorstenbosch harry.vorstenbosch at zonnet.nl
Tue Feb 14 13:20:25 GMT 2006


Howard,

I do not know if it could be at any help for you, but I have compared
your xorg.conf file with mine, and herewith I show you (only) the
differences:(Mine Graphics card is an ATI RV350 AR with a Targa
Visionary LCD 17-4 connected to).  

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
	FontPath	"/usr/share/X11/fonts/CID"
        # paths to defoma fonts
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
	Load	"GLcore"
	Load	"i2c"
EndSection

Section "Device"
	Identifier	"ATI Technologies, Inc. Radeon 9600 XT (RV350 AR)"
	Driver		"ati"
EndSection

Section "Monitor"
	Identifier	"Generic Monitor"
	Option		"DPMS"
	HorizSync	28-64
	VertRefresh	43-60
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"ATI Technologies, Inc. Radeon 9600 XT (RV350 AR)"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1280x1024" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "ServerLayout"
	Screen		"Default Screen"
EndSection
=====================================================================

I hope this could be of any help.

Greetings Harry,



On Mon, 2006-02-13 at 21:35 -0600, Howard Coles Jr. wrote:
> This is going to be a two part post due to one message being too big.
> 
> Ok, I've done just about everything I can think of, and whatever I could find 
> on the web and I can't figure out why I cannot get hardware acceleration to 
> work on my ATI Radeon 9100!
> 
> I have the fglrx modules from dapper, and if anyone can offer some help I'll 
> post versions, etc.  On second thought here they are:
> xorg-driver-fglrx 6.9.0-8.21.7+2.6.15.5-2
> xserver-xorg 7.0.0-0ubuntu14
> xserver-xorg-core 1:1.0.1-0ubuntu5
> 
> I have a an ati driver package that I question:
> xserver-xorg-driver-ati 1:6.5.7.3-0ubuntu1
> 
> I do have the linux-restricted-modules-2.6.15 package installed (for the 
> madwifi drivers).
> 
> here is my xorg.conf file:
> 
> 
> # /etc/X11/xorg.conf (xorg X Window System server configuration file)
> #
> # This file was generated by dexconf, the Debian X Configuration tool, using
> # values from the debconf database.
> #
> # Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
> # (Type "man /etc/X11/xorg.conf" at the shell prompt.)
> #
> # This file is automatically updated on xserver-xorg package upgrades *only*
> # if it has not been modified since the last upgrade of the xserver-xorg
> # package.
> #
> # If you have edited this file but would like it to be automatically updated
> # again, run the following command:
> #   sudo dpkg-reconfigure -phigh xserver-xorg
> 
> Section "ServerLayout"
> 	Identifier     "Default Layout"
> 	Screen         "Default Screen" 0 0
> 	InputDevice    "Generic Keyboard"
> 	InputDevice    "Configured Mouse"
> 	InputDevice    "Synaptics Touchpad"
> EndSection
> 
> Section "Files"
> 
> 	# path to defoma fonts
> 	FontPath     "/usr/share/X11/fonts/misc"
> 	FontPath     "/usr/share/X11/fonts/cyrillic"
> 	FontPath     "/usr/share/X11/fonts/100dpi/:unscaled"
> 	FontPath     "/usr/share/X11/fonts/75dpi/:unscaled"
> 	FontPath     "/usr/share/X11/fonts/Type1"
> 	FontPath     "/usr/share/X11/fonts/100dpi"
> 	FontPath     "/usr/share/X11/fonts/75dpi"
> 	FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
> EndSection
> 
> Section "Module"
> 	Load  "bitmap"
> 	Load  "ddc"
> 	Load  "dri"
> 	Load  "extmod"
> 	Load  "freetype"
> 	Load  "glx"
> 	Load  "int10"
> 	Load  "type1"
> 	Load  "vbe"
> EndSection
> 
> Section "InputDevice"
> 	Identifier  "Generic Keyboard"
> 	Driver      "kbd"
> 	Option	    "CoreKeyboard"
> 	Option	    "XkbRules" "xorg"
> 	Option	    "XkbModel" "pc104"
> 	Option	    "XkbLayout" "us"
> EndSection
> 
> Section "InputDevice"
> 	Identifier  "Configured Mouse"
> 	Driver      "mouse"
> 	Option	    "CorePointer"
> 	Option	    "Device" "/dev/input/mice"
> 	Option	    "Protocol" "ExplorerPS/2"
> EndSection
> 
> Section "InputDevice"
> 	Identifier  "Synaptics Touchpad"
> 	Driver      "synaptics"
> 	Option	    "SendCoreEvents" "true"
> 	Option	    "Device" "/dev/psaux"
> 	Option	    "Protocol" "auto-dev"
> 	Option	    "HorizScrollDelta" "0"
> EndSection
> 
> Section "Monitor"
> 	Identifier   "Toshiba LCD Widescreen"
> 	HorizSync    30.0 - 67.0
> 	VertRefresh  30.0 - 60.0
> 	Option	    "DPMS"
> EndSection
> 
> Section "Device"
> 	Identifier  "ATI Technologies, Inc. Radeon Mobility 9100 U3 (R200 IGP)"
> 	Driver      "fglrx"
> 	VideoRam    131027
> #	Option	    "UseFBDev" "true"
> 	Option	    "UseInternalAGPGART" "yes"
> 	BusID       "PCI:1:5:0"
> EndSection
> 
> Section "Screen"
> 	Identifier "Default Screen"
> 	Device     "ATI Technologies, Inc. Radeon Mobility 9100 U3 (R200 IGP)"
> 	Monitor    "Toshiba LCD Widescreen"
> 	DefaultDepth     24
> 	SubSection "Display"
> 		Depth     1
> 		Modes    "1280x800" "1024x768" "800x600" "640x480"
> 	EndSubSection
> 	SubSection "Display"
> 		Depth     4
> 		Modes    "1280x800" "1024x768" "800x600" "640x480"
> 	EndSubSection
> 	SubSection "Display"
> 		Depth     8
> 		Modes    "1280x800" "1024x768" "800x600" "640x480"
> 	EndSubSection
> 	SubSection "Display"
> 		Depth     15
> 		Modes    "1280x800" "1024x768" "800x600" "640x480"
> 	EndSubSection
> 	SubSection "Display"
> 		Depth     16
> 		Modes    "1280x800" "1024x768" "800x600" "640x480"
> 	EndSubSection
> 	SubSection "Display"
> 		Depth     24
> 		Modes    "1280x800" "1024x768" "800x600" "640x480"
> 	EndSubSection
> EndSection
> 
> Section "DRI"
> 	Mode         0666
> EndSection
> 
> END xorg.conf
> 
> See reply to this message for xorg.0.log file
> 
> -- 
> 
> See Ya'
> Howard Coles Jr.
> John 3:16!
> 
> Christian Books On-Line http://risenbooks.com
> http://home.comcast.net/~dhcolesj
> 




More information about the kubuntu-users mailing list