k3b permissions error

Derek Broughton news at pointerstop.ca
Mon Dec 11 18:29:18 UTC 2006

Paul Kaplan wrote:

> On Saturday 09 December 2006 9:17 am, D. Michael McIntyre wrote:
>> On Saturday 09 December 2006 6:59 am, Dotan Cohen wrote:
>> > Paul, as much as I'm going to get flamed for this, I always run k3b as
>> > root. It's the only 100% sure way to avoid those permissions problems
>> I'm not going to flame you.  I have to do this too, and I don't
>> understand
>> why.  K3B scans for permissions at startup, and does not detect any
>> problems. If I run the setup utility manually, it finds nothing to
>> complain
>> about.  Yet whenever I try to burn something, I get a message similar to
>> "I/O Error!  See log for details."  The log is always empty of any clue
>> at
>> all.  It just fails for no apparent reason, and I have no clue what to do
>> about it.
>> It's got to be permissions on something that k3bsetup doesn't check for,
>> but what?  I've tried to strace it to no avail, tried various other
>> ideas. At the end, I just run it as root and sigh.
> Yeah.  I've tried setting the suid bit on /usr/bin/cdrecord,
> /usr/bin/cdrdao,
> and /usr/bin/cdparanoia.  Obviiously something else is needed.
> Clearly a bug or oversight in k3bsetup, unless it's a feature...but for
> what purpose?

I wouldn't _flame_ you for running as root - but it's not the right way to
do it :-)

What's the device name of your burner?

More information about the kubuntu-users mailing list