Mounting of USB devices broken in Dapper? - SOLVED

Vayu vayu at
Tue Dec 5 02:59:07 UTC 2006

Is it the 18.2 versions that don't work? When looking in synaptic, it 
shows I have 18.2 installed, can I just install 18.1 over that? What 
about some of the other HAL libs that also show 18.2, do I have to track 
down everything 18.2 and replace with 18.1?

I did a dist-upgrade to get those packages. After that my system would 
lock up after 10 min. I played around with a bunch of stuff, finally got 
it working (one of those I don't know what I did right times, possibly 
unrelated beryl problem) except that the automount is now worse than before.

Before it wouldn't show an icon, but I could go to /media and see the 
device there. If it was a memory card I could then right click to safely 
remove, now the devices don't even appear in /media. Also the initial 
dialog that would come up to open still comes up but closes and does 
nothing when I click ok. lsusb shows the device, I don't know what to 
check beyond that.

I have no access any more. What would be the /dev/?? to try to manually 

$ lsusb
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 001 Device 002: ID 0781:9219 SanDisk Corp.
Bus 001 Device 001: ID 0000:0000

Steve wrote:
> On Sun 3 December 2006 18:31, Urtzi Jauregi wrote:
>> On Saturday 02 December 2006 23:28, you wrote:
>>> It started earlier. See my previous posts about a week ago. I
>>> solved the problem going back to the debs from Jonathan Riddell
>>> KDE 3.5.5 (they have a "1" in the end, rather than a "2"). All
>>> works fine now. I suggest that maybe the upstream (Ubuntu
>>> official) debs didn't get the changes Jonathan applied to these
>>> packages.
>> 	This solved it. I went to
>> ,
>> downloaded the package hal_0.5.7-1ubuntu18.1_i386.deb , installed
>> it and restarted the computer. Voila! My icons are back; now
>> everything works like it should.
>> 	Thank you everybody for your input; now let's hope the developers
>> fix the official hal package as soon as possible . . .
>> 	- Urtzi -
>> --
>> Urtzi Jauregi
>> Fakulteta za Matematiko in Fiziko, Univerza v Ljubljani
>> Jadranska 19, Si-1000 Ljubljana
>> Slovenija
>> Tel: ++386 01 540 13 53
>> e-mail: urtzi at
> Thanks for the fix worked great.....that bug was annoying me
> steve 

More information about the kubuntu-users mailing list