dapper: evdev not working? (additional mouse buttons)

Christoph Wiesen chris at deadhand.com
Wed Apr 26 16:20:39 UTC 2006


Hello,

I'm using dapper for some time now. Previously I was using hoary and another 
distro in between. I've been using "evdev" on both previous installations to 
have access to all of my mouse keys (specifically in games). That worked ok - 
at least i could use two of the side buttons (buttons 4 and 5).

With dapper I've got less luck - I didn't manage yet to have evdev work or to 
get my additional mouse buttons to work another way.

Is someone on this list using evdev successfully?

I'm using this config (same as on hoary before) in xorg.conf:

Section "InputDevice"
 Identifier "Configured Mouse"
 Driver     "evdev"
 Option     "CorePointer"
 Option     "Device"    "/dev/input/mx1000"
EndSection

I'm creating the device mx1000 with udev at boot time first:

In /etc/udev/rules.d/010_local.rules:

ACTION=="add", \
  SUBSYSTEM=="input", \
  SYSFS{manufacturer}=="Logitech", \
  SYSFS{product}=="USB Receiver", \
  NAME="input/mx1000"


But I tried to use /dev/inpute/moce in xorg.conf isntead, in case anything is 
wrong with the udev part - I get the same error:

With this I can't launch X. Instead I get this message on tty7:

*** glibc detected *** malloc(): memory corruption (fast): 0x08247u48 ***


I created a ug report for this: https://launchpad.net/bugs/39878


Maybe I'm doing something wrong? Somebody got any idea how I might enable the 
additional mosue buttons?

Chris




More information about the kubuntu-users mailing list