kpowersave - suspend terminates KDE

lordsauronthegreat at lordsauronthegreat at
Sun Apr 23 20:56:20 UTC 2006

On Sunday 23 April 2006 08:46 am, Derek Broughton wrote:
> On a fresh install of kpowersave / powersaved, when I suspend-to-disk from
> kpowersave the running KDE session is not suspended, it's simply terminated
> (not even a proper session exit). I had them installed before and the
> suspend worked perfect, and I suspected my twiddling might have caused this
> so I purged both packages and reinstalled.  Has anyone else tried this?

Yes, I had similar problems.  The same story is true of Gentoo (which I use 

Be careful!  All this ACPI stuff is so darn experimental.  It doesn't work 
that well either...  I'm hearing more and more rumours of them dumping all 
ACPI stuff altogether.

If your laptop starts to slow down a lot, you may have killed your swap 
partition.  Fix it by:

# mkswap [your swap partition, ex. /dev/hda2]
# swapon [your swap partition]

When I had a failed suspend-to-disk, it killed my swap partition and I had to 
revive it in that manner.

May the Force be with you!
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 191 bytes
Desc: not available
URL: <>

More information about the kubuntu-users mailing list