Annoying Problems with User Accounts

Howard Coles Jr. dhcolesj at gmail.com
Sat Apr 15 21:51:53 BST 2006


On Saturday 15 April 2006 15:38, Richard Crawford wrote:
> On Saturday 15 April 2006 13:26, Howard Coles Jr. wrote:
> > > 2.  Removable Media.  I can mount a USB camera just fine under my
> > > account, but not under my wife's account -- it says that /dev/sda1 was
> > > not found in /etc/fstab or /etc/mtab.  I really don't understand this
> > > one since it works just fine under my own account.
> >
> > Check the permissions on the devices you just mentioned.
> > I have found that dispite the rules, udev creates my /dev/null with root
> > only permissions, and I've found that some other devices are similar. 
> > Your account may be in a group that has permissions, but your wife's
> > account may not be, etc.
>
> Howard,
>
> Thanks for responding.
>
> I did set the permissions on /dev/sda1 to 777, but that didn't seem to make
> a difference.  Is that what you meant?

Well, yea, kinda.  I was just wondering what can your wife's account see in 
the /dev directory?  It could be that she can't see anything.  Another thing 
I"m wondering is if there is a difference in groups, etc. in your wife's 
account and yours.  /dev should have permissions:  766.
However, you may want to back off those permissions for /dev/sda1 to 660 
because /dev/sda1 is not a directory, so executable is not needed.  (Also 
make sure root is the owner of the devices and disk is the group.)

-- 

See Ya'
Howard Coles Jr.
John 3:16!

Christian Books On-Line http://risenbooks.com
http://home.comcast.net/~dhcolesj



More information about the kubuntu-users mailing list