The wifi crusade.

Pupeno pupeno at pupeno.com
Mon Apr 3 12:54:21 BST 2006


Many hardware doesn't work because it is priopietary and the manufacturer 
doesn't support freedom (by releasing specs and/or free drivers), if that is 
the case you bought the wrong hardware. In the case of wifi you might find 
that there's almost no good hardware. Please, don't forget to tell the 
manufacturer how angry you are because you actually bought a product and they 
didn't release enough information to let you use it. When manufacturers get 
enough complaints they might start to change and it'll be easier for all of 
us.
And as I write this I remember that I haven't seen a complaint to SoftLink for 
making such a crap and calling it modem.
Thank you.

On Saturday, 1 de April de 2006 15:00, tchize wrote:
> Hello,
>
> Today, i decided to buy a wifi PCI card, to get rid of this nice wire
> in the house. My laptop was already using wifi, it was time for my
> upstair desktop to go wireless. I have a reflex when it comes to brand
> new card when they do not seem automatically working on my linux box:
> test how the manufacturer drivers behave on aimed OS (mainly windows
> for most) to ensure the card is not defect.
>
> Windows installation: put that awfull driver CD in tray, install
> drivers, go to the wifi configuration panel just click 'scan' and then
> give your password for the select wifi gateway (and specify the
> encryption type). Total time of operation from install driver to use
> browser: 5 minutes.
>
> Kubuntu installation: Drivers is recognized immediatly by kernel
> (rt2500 card) and loaded (great!). I go to kde network config panel
> and .. Outh, forgot that panel is not working in breezy badger, so i
> go to the net, find some tutorial and go by hand in
> /etc/network/interface.
>
> I add this:
>
>
> iface ra0 inet dhcp
>         pre-up iwconfig ra0 essid Ayato
>         pre-up iwconfig ra0 mode Managed
>         pre-up iwpriv ra0 set Channel=8
>         pre-up iwpriv ra0 set AuthMode=WPAPSK
>         pre-up iwpriv ra0 set EncrypType=TKIP
>         pre-up iwpriv ra0 set WPAPSK="<my key>"
>         pre-up iwpriv ra0 set TxRate=0
>
>
> Parameters AuthMode, WPAPSK, TKIP and the key is exactly the same i
> used under window
>
> Then i type
> tchize at Urd:~$ sudo ifup ra0
> Internet Systems Consortium DHCP Client V3.0.2
> Copyright 2004 Internet Systems Consortium.
> All rights reserved.
> For info, please visit http://www.isc.org/products/DHCP
>
> sit0: unknown hardware address type 776
> sit0: unknown hardware address type 776
> Listening on LPF/ra0/00:08:a1:98:d4:c3
> Sending on   LPF/ra0/00:08:a1:98:d4:c3
> Sending on   Socket/fallback
> DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 7
> DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 15
> DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 15
> DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 13
> DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 7
> DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 4
> No DHCPOFFERS received.
> No working leases in persistent database - sleeping.
>
>
> Ok, i wasn't able to get a dhcp lease from wifi gateway. (note, i
> tried with a static ip too, no help in getting connect)
> to ensure driver is working properly , i issue a network scan:
>
> tchize at Urd:~$ iwlist ra0 scanning
> ra0       Scan completed :
>           Cell 01 - Address: 00:11:50:7E:F5:68
>                     Mode:Managed
>                     ESSID:"Ayato"
>                     Encryption key:on
>                     Channel:8
>                     Quality:61/100  Signal level:-65 dBm  Noise
> level:-193 dBm
>
> So the driver itself is working properly.
>
>
> Total time: 3 hours work, attempting various config, i am still not
> able to connect  to wifi gateway and no error message at all to
> provide informations on what could be wrong, except the fact dhcp
> don't get a lease! The wire cable is still there...
>
>
> Conclusion: If you want to go wifi go windows or mac os x?
>
>
>  I hope not! Does someone has a solution to this problem?
>
>
> Thanks.

-- 
Pupeno <pupeno at pupeno.com> (http://pupeno.com)
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : https://lists.ubuntu.com/archives/kubuntu-users/attachments/20060403/cd2d46f7/attachment.pgp


More information about the kubuntu-users mailing list