Big Problem with Apt-Get

James Gray james at
Sun May 1 07:09:20 UTC 2005

On Sat, 30 Apr 2005 08:05 pm, Dave - wrote:
> Appreciate the help guys but nothing seems to work. I've tried every type
> of removal, purge, update, upgrade, force, etc. I'm about ready to
> reformat and reinstall kubuntu. It maybe did have something to do with
> the marillet sources I added. Thanks to the Unofficial Hoary guide. :-(
> Basically my sources.list consisted of all Hoarys including universe and
> multiverse plus the three marillets.
> Searched everywhere online for hours and hours. Oh, well. So any more
> suggestions on how to prevent something like this from happening again?
> I'm not new to linux but this is my first debian-based distro. Thanks.
> Dave

You may have a corrupted download.  Which means two options:

1. Purge (clean) the package cache to force apt to download the package 
again. ie, "sudo apt-get clean ; apt-get upgrade".  However, this will 
remove ALL previously downloaded packages - worst case scenario; you need 
to download stuff again if you intend "reinstalling" a package you already 

2. Go to /var/cache/apt/archives and delete the offending package(s) deb 
file.  Then simply redo the operation you attempted in the first place 
"sudo apt-get upgrade".

If both fail, then you may need to remove packages then try the upgrade 
again and then reinstall the packages you removed.  I had this problem last 
week with kdelibs - the "upgraded" version was trying to over write a file 
from kdenetwork.  So I "apt-get remove kdenetwork" then "apt-get upgrade" - 
this installed kdelibs without errors or "forcing", then simply "apt-get 
install kdenetwork".  Problem solved.

apt with deb's is MUCH better than basically every RPM-based system I've 
used (SuSE/RedHat/Fedora/Mandriva - not starting a holy war, just 
recounting my experience).  That said, sometimes you need to work around 
slightly broken packages doing a remove-upgrade-reinstall cycle (like I 
described above with kdelibs).

Good luck with it all :)


The world's as ugly as sin,
And almost as delightful
		-- Frederick Locker-Lampson
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <>

More information about the kubuntu-users mailing list