<font face="Default Sans Serif,Verdana,Arial,Helvetica,sans-serif" size="2"><div>Hi there,</div><div><br></div><div>I have noticed some kind of strange behavior in Kubuntu 14.04 and perhaps some of you know the cause and perhaps how to fix it.</div><div><br></div><div>The environment</div><div>Kubuntu 14.04 and 12.04</div><div>SSSD and Kerberos Authentication in a Active Directory infrastructure.</div><div><br></div><div>Bug:</div><div>When changing the primary group in Kubuntu 14.04 to one I am already member of I get asked for a password and after pressing Enter</div><div>"Crypt: Invalid argument."</div><div>This only affects groups that are part of the Active Directory, not any other, neither from a true openldap server nor local groups. Only when trying to change to an Active Directory group this behavior can be seen.</div><div><br><br></div><div>By trying this in Kubuntu 12.04 everything works fine. It works also in RHEL5 and RHEL6 that are also part in our environment.</div><div><br></div><div>I made an strace in Kubuntu 12.04 and in Kubuntu 14.04 when doing the newgrp cmd to change my primary group. After comparing I noticed, that the newgrp cmd in Kubuntu 14.04 does not read the file /etc/login.defs which is normally read as one of the first files at all by doing this command.</div><div><br></div><div>For a better understanding I send you the straces itself as attachment. Please help me in this case.</div><div><br></div><div>Kind regards</div><div><br></div><div>Marco</div><div></div></font>