experiences alpha 2

Xen list at xenhideout.nl
Fri Jan 30 21:13:14 UTC 2015


completely new to Kubuntu and Linux :p, but I had the wish to get Kubuntu 
Vivid on Ubuntu Server with some kind of LUKS setup.

Experiences thus far, in short:

- Vivid installer is fine, no issues. Encryption is dysfunctional though. 
I constantly got the error that a key could not be created, this didn't 
happen the first time for some reason, but after reverting/going back, and 
even doing new live session runs, I could not get any form of LUKS setup 
due to that error.

Furthermore, of course, the graphical installer doesn't allow for much 
manual configuration, in particular no LVM setup.

After that, or perhaps before, I had been struggling with Ubuntu Server 
14.10. The setup / installer program is way out of this world, but there 
was also an issue with activating an existing encryption scheme, it would 
stall at some "73%" mark every time. So I had to recreate the scheme every 
time, a time-consuming process. It also was not capable of loading a root 
(mounting a root) filesystem inside of an LVM when this root was 
encrypted; I see now that the regular setup is to get LVM within the 
encryption, and not the other way around -- I am talking about the 
installer rescue system.

The server system furthermore became ..corrupted in a sense when I tried 
to add keyscript=decrypt-keyctl  (or decrypt_keyctl) (whatever it was) to 
the crypttab options.

At that point I reinstalled with the rescue option (from the Server 
installer image) but then my system wouldn't boot anymore at all. Anyway.

It was at that point that I decided to go with the non-manual, 
complete-disk LVM encryption (LUKS) install from 15.04 Kubuntu.

Which worked fine.

(( --> The only Issue I have with the regular Ubuntu LUKS (I have no 
experience with others) is that the LUKS prompt displays the UUID and 
device of the encrypted system, ie. it will normally show sda5_crypt. This 
is information you do not want an attacker to have. Ideally you do not 
even want the attacker to know about encryption at all. You just want a 
password prompt that will activate a system.

"A passphrase is required to boot Kubuntu 15.04 Vivid Vervet. Please 

That is the kind of thing a sensitive encryption designer would build 
(that I am hoping to become :p ;-)).

(I want at some point to develop something for a NAS brand).


So my goal was to install Kubuntu desktop environment with all the apps, 
on Ubuntu Server, but because of all the failings, as well as that my wifi 
had some driver issue with the RF_KILL switch being 'on' (radio disabled) 
and I had no internet access at the time so I wasn't able to discover how 
to enable it. (I believe I needed the rfkill program. How obvious....).

Subsequently my new goal was to install a headless Debian server. Debian 
uses the same installer as Ubuntu Server, at least the text-based one, I 
haven't tried the graphical one.

Debian 7.8.0 Gnome is BUTT ugly.

In a world that perhaps tends to not take good care of butts.

But regardless, and anyway.

One issue I ran into is when I had tried to get a form of fixed eth0 LAN 
configuration through the system tray and/or System Settings (that didn't 
have any) -- (It seems older versions of Kubuntu had much more in terms of 
content in that settings thing??).

Is that there was a "start wait-for-state WAITER=whoopsie 
WAIT_FOR=network-manager GOAL=start" that kept removing my IPv4 address 
when I had entered it in /etc/network/interfaces.

Sometimes, often, within seconds after doing ifdown eth0; ifup eth0, it 
would have deleted the IPv4 again.

So for some time I was connecting to that Debian server (now installed in 
a testing way) with a few seconds of window of being able to use that 
network link.

Until I decided to kill that process just mentioned, then it was over.

Anyway, my success thus far is:

- having a Kubuntu laptop with standard regular LUKS for the entire LVM 
(sda5, entire partition).

Except for a 500k sector (250MB) boot partition. I mean entire drive save 
for the boot.

- having a headless Debian server that I can wake-on-lan, that will 
auto-resume / boot on power-connect (power-restore) and that has an 
apparently software RAID card that threatens to delete all my data 
(installation) when I want to delete the array ("THIS WILL DELETE ALL YOUR 
DATA") and I still don't know if it will execute that threat.

I like thread execution but this one is beyond me.

Pun intended, anyway.

((- The raid card (Sil3114) is apparently something that only works when a 
driver is loaded, which defeats the purpose entire of having a hardware 
solution :-/. And it doesn't even do or did or done anything to my drives, 
it just has an array and it says it will ruin my disks.

But it prevents my BIOS from booting the individual drives.

And I wish I could just wipe its memory but I think I should at least just 
disable its BIOS, it has a jumper for that (Dawicontrol 154).

-)). Anyway the drives are now connected (2 disks) to the regular 
mainboard and the Debian system has now a complex RAID setup configured in 
software, thanks be to the excellent text-mode installer.

((- The only point now for that card is to have eSata x2, apparently).

But, I guess back to Kubuntu then.

The lack of manual (success) with encryption and, as well as the lack of 
LVM support was for me the most annoying thing and kindof a deal breaker 
but I needed a running system.

I still want Ubuntu Server with kubuntu-plasma5-desktop.

I was wanting to execute:

sudo apt-add-repository ppa:kubuntu-ppa/next
sudo apt update
sudo apt install kubuntu-plasma5-desktop
sudo apt full-upgrade

..but I never got as far as to have wifi.

(-- Because the raid card also did not have EUFI I just went GPT with BIOS 
and installed grub in the "BIOS Boot Partition". Of the second disk in the 
array. While the first disk has a regular boot partition and is mounted as 
/boot. So now sda1 has the grub files, but sda2 has the bootloader, and it 
works just fine :p. I was needing to experiment because I didn't know if 
the one or the other would work. Apparently the "Reserved BIOS Boot Area" 
was required for GPT grub, and I wasn't aware that it was just meant to 
hold 1 MB of 'data'.

(((The system has a multitude of identical partitions, the two drives are 
set up exactly the same. Everything is in RAID (some 0, some 1, some with 
a LVM VG inside and 2 volumes) except for the boot partitions. So 
currently my /boot is on sda1, whereas the "Reserved BIOS Boot Area" is on 
sda2 (also 500 meg lol). But the installer allowed me to set a mount-point 
for sda2. There is no filesystem on it though. And if I format it I will 
probably lose my bootloader.))). (I think it is a pretty neat setup 
actually even though I did not intend it.). But now I need two disks to 
boot, which I need anyway... Hm...). I wonder ).....


Other than that, I have had no issues with 15.04 compared to a (live 
session only) of 14.10.

I cannot set wifi to automatically connect, and often when I click the 
icon I get something else instead. (Such as the devices icon). I really 
like the mouse-pointer behaviour of KDE though.

At least with this trackpad.

I have a wifi killswitch icon though that keeps flashing when there is a 
link active. In Windows the icon is a steady blue; red means off, now it 
is always flashing.

I think it is an Intel Wifi 5100 AGN.

More users (in the past, for various distributions) have reported problems 
with it. These problems all seemed (from my quick search) to involve the 
killswitch being activated when not being the desired outcome. So these 
users had had to use that rfkill unblock all to get their wifi going 
again, regularly. Or at bootup. Whatever. There is a funky thing about it 
that when you boot straight from Windows, it works, but after a Linux 
reboot, it fails to work. The Debian Installer had found and activated my 
wifi link, but on subsequent reboot the icon went dead (red). So the 
driver (that is supplied by Intel, I believe) does something very weird.

I installed from ISO, DVD.

Laptop is HP Elitebook 2530p. Regular 1.8" SATA hdd. Nothing special that 
I can see.

On boot, when the GUI gets loaded, the lower part of the screen regularly 
does a bit of 'flashing'. It is quite ugly as part of a ..an elegant 
welcome screen, kinda ruins the beauty of the environment for those 20 

Graphics is Intel GS45 Express / Intel GMA 4500MHD Integrated Graphics.

Laptop never had any issues of any kind with Windows 7.

Nor there really any other issue other than the flashing wifi icon. Wifi 
works fine in Kubuntu.

I just miss a mapping for the windows key. The only shortcuts I've learned 
thus far are.... none. Alt-f2 still works. A thing from the past for me.

Other than that I am still unaware of any system-wide shortcuts, and 
resizing windows is a pain.

Konsole won't honour my changed settings for the columns/rows. I can set 
it to 100x40 or 120x40 500 times, and change all the options that are 
mentioned (next window gets current size, etc.) but it never works. The 
font can be changed though, and its size.

I like the more advanced windowing options (compared to Windows) but there 
are also no shortcuts mentioned.

Other than that, the contrast in Plasma5 is obviously completely wrong for 
a user experience that enables good perception for what you need. The 
transparancy-upon-window-relocation is not helpful. The transparency of 
the "start menu" is not helpful. Even a single window (such as a browser) 
beneath it can render it completely dysfunctional. The spacing is bad, the 
"type to search" is not very logical or intuitive (because there is no 
search field there) (to begin with) -- the menu is pretty much worthless 
because "folders" or "submenu" items are not identifiable as such, or set 
apart from other entries. The fact that there is both a "functional name" 
for each program ("Drawing Tool") is excellent - and also the real 
program name ("LibreOffice Draw") but the real name is so greyed out that 
it escapes being read while not escaping attention.

Which obviously frustrates.

There is this theory that is my theory that says that a colour's alpha 
value (with 100% being fully oblique) should be identical to a colour's 
lightness (in the HSL model) because the alpha is about information value, 
while the lightness is about passive attention grabbing. More (higher) 
information allows for more attention to be 'asked' while having not a lot 
of attention while giving a lot of information, causes problems of being 
'underrepresented' or 'underheard or underseen'. Since many colours in 
regular computer system have full alpha but reduced lightness (because the 
only colour with full lightness is pure white) those colours habitually 
provide a lot of information while not getting enough attention (in the 
passive way, saturation in that system is a measure of active attention 

In this case I would say it seems to just escape being seen while having a 
lot of information. But it can also be a contrast thing, I haven't worked 
that out yet. Lowering a colour's alpha AND lightness on a dark background 
obviously creates problems even though the situation may seem harmonic to 
the eye. I am still looking into experiments to see how I can use e.g. 
GIMP to enhance the contrast in pleasing way, but it has been a long time.


In any case that seems like stuff not particular to Kubuntu but rather KDE 
as a whole. I am pleased to have this alpha version to work with. I like 
being at the cutting edge currently because I want to do cutting edge 
things now and then.

But Kubuntu KDE (15.04 at least, but it was not very different with 14.10) 
seems rather a primitive desktop environment, even when it is beautiful 
graphically. The graphical style is just wonderful and elegant and 
meaningful to me. The way some current solutions (e.g. some NAS 
manufacturer's newest version of their OS) just break away from elegance 
just in order to change or improve something, anything, even if it doesn't 
need improvement, or not in that way....

Managerial mark-making impulse.

I have seriously not ever seen a computer environment so beautiful as 
plasma5. It is even better in those terms than plasma4.

It is just that many contrasts are off or bad or wrong, and the 
environment itself does not make a lot of sense to me. It is like a 
meditation of looking at beauty, but the beauty is incomprehensible :p.

I don't even know or remember how to show the desktop or minimize all 

There is something in the top-left corner that functions as Expose, from 
MacOS, but only rarely. I cannot get it to consistently do anything.

I absolutely dig the clipboard system tray icon, it is someting I have 
always missed in every OS I used.

They always say, if you have never had anything, you also cannot miss it 
or "he doesn't know what he is missing" but I disagree with the sentiment, 
I think indeed we can be aware of the things we have never had and that we 
long for incessantly, because we have lived a time when all the things we 
now lack, were once ours. And many people indeed are or have become 
unaware of these things because they ruin their lives and bodies with 
poisons, tobacco, alcohol, dirty soaps and shampoos, polluted and cheap 
food, and television, to name a few things ... and in the end you cannot 
even remember whether you felt good as a child when all these things were 
still absent from your life. And people just accept it as a necessity of 
life that you go down. That you lose your sensitivity.

And the people that do feel something, are then chastised as being "too 
sensitive". In a world that habitually causes pain to basically everyone.

Anyone who actually feels anything would then indeed be at a point or 
place of experiencing a lot of pain.

But that doesn't mean the others don't go with hunched backs and bent 

And it doesn't mean they live a full and fulfilling life. Either.

Or not at all.

Anyway. I am glad...

...that the KDE designers have some sensitivity in them left.

I'll close with that.


Xen.... or Bart, whatever.

More information about the kubuntu-devel mailing list