gstreamer0.10-ffmpeg and how we won't have it for 14.04

Valorie Zimmerman valorie.zimmerman at
Tue Mar 25 08:52:59 UTC 2014

On Tue, Mar 25, 2014 at 1:29 AM, Harald Sitter <apachelogger at> wrote:
> General note, since apparently I did not mention this on IRC yet.
> You *can not*, no, in fact you *must not* have any software that can
> or could or somehow might use gstreamer1, also can or could or somehow
> might use gstreamer0.10. Much like Qt4 vs. Qt5 there's symbol clashes
> at runtime that are going to crash applications in the most obscure
> and unnecessary fashion.
> HS

Do we have a technical way to make it impossible for people to install
software that will clash with what they already have, whether that be
gst1, or gst0.10? So if they are installing Application New, that it
will be reported:

Installing $AppNew
Uninstalling $AppOld

If we have such a technical way, is it possible for us to do that
before release?


More information about the kubuntu-devel mailing list