4.7 natty backports incomplete

Ingo Ratsdorf ingo at envirology.co.nz
Thu Aug 11 04:29:16 UTC 2011



On Wed, 10 Aug 2011 17:50:45 O. Sinclair wrote:
> On 10/08/2011 17:42, Kristóf Kiszel wrote:
> > http://www.kubuntu.org/news/kde-4.7
> >
> > "KDE PIM 4.7 won't be shipped together with our KDE SC 4.7 packages
> > until more testing has been done. To help with testing it you need to
> > use the Software Repository Guide to add the Kubuntu Experimental PPA
> > to your software sources list:
> > ppa:kubuntu-ppa/experimental"
> >
> > 2011/8/10 Ingo Ratsdorf<ingo at envirology.co.nz>:
> >> I installed the natty 4.7 packages and found them incomplete.
> >> Akonadi and various other packages are 4.7 whereas the whole of KDEPIM is still 4.4.10.
> >> This breaks some important KDE PIM things. KOrganizer can still not see subfolders, groupdav resource is not 
available
> >> and KIO_HTTP in kdelibs is suffering from the phishing "feature" regression that has been deleted in the latest 
4.7
> >> kdelibs  (on oneiric for example).
> >>
> >> When will all the packages provided as already happened (happening) for oneiric?
> >>
> >> Kde 4.7 is a massive leap in terms of KDE PIM - finally groupdav, carddav and caldav working....
> >>
> >> Cheers,
> >> Ingo
> >>
> >>
> >> --
> >> kubuntu-devel mailing list
> >> kubuntu-devel at lists.ubuntu.com
> >> Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-devel
> >>
> >
> in my humble opinion that was/is the correct choice. Kontact 4.6 was NOT 
> ready for "production use" in the test run I did and as I have noted 
> from other forums/internet search the distro(s) that did package it with 
> SC 4.7 are having loads of unhappy users trying to come to terms with 
> various problems relating to upgrade of kde-pim.
> 

Well, I agree that there were some "teething" problems, of which most were realted to incorrectly migrated settings. 
I had to delete the Akonadi SQL database and reconfigure all Akonadi agents, but from what I can tell so far, it runs 
surprisingly stable on my 8 year old laptop...

Further, IT IS UTTERLY IMPORTANT that kdelibs have to be upgraded, or at latest kioslave/kio_http, which is 
suffering from a severe bug re phishing prevention that was fixed in 4.7. This bug is currently present in the Kubuntu 
packages and BREAKS all *DAV access. It pops up with a nasty warning about possible tricking every time you log into 
any HTTP url that needs authentication.
https://bugs.kde.org/show_bug.cgi?id=94867

Regards,
Ingo




More information about the kubuntu-devel mailing list