wpa and broadcom card

chuck adams chuck.adams.k7qo at gmail.com
Tue Oct 20 02:59:27 BST 2009

On Mon, 2009-10-19 at 22:39 -0300, Juan wrote:
> 2009/10/19 Jonathan Jesse <jjesse at gmail.com>:
> > updates today fixed my problems, will let yo uknow if I continue to have
> > problems.
> >
> > Thanks guys :)
> Hi guys, I'm gonna install and test. Thanks if the problem is solved!.
> Juan

I installed todays ubuntu karmic-netbook-remix-i386 iso and created
bootable USB memory.  Installed into a lenovo s10 netbook.

No detection of broadcom bcm4312 card.

Use an Airlink101 atheros based USB wifi to connect to Internet.
Used synaptic package manager to download and install
bcmwl-kernel-source.  Rebooted system and removed the Airlink USB

Still no Broadcom seen on the upper task bar wifi icon.

Checked using hardware driver tools and it shows Broadcom
card drivers as active.

lsmod | grep wl


lib80211  # 0 lib80211_crypt_tkip,wl

I am using a linsys/cisco router with WPA/WPA2 enabled,
so is that a problem.  With the Airlink it requested the
password phrase and everything was up and running.

I'm able to use the USB connection, but I'd prefer to use
the internal wifi hardware, if possible.

Let me know if I need to run some more tests to help.



More information about the kubuntu-devel mailing list