wpa and broadcom card

Juan juan at rodriguezmonti.com.ar
Mon Nov 9 02:49:31 GMT 2009

2009/11/8 Scott Kitterman <ubuntu at kitterman.com>:
> On Sun, 8 Nov 2009 19:40:11 -0300 Juan <juan at rodriguezmonti.com.ar> wrote:
>>2009/11/8 Jonathan Jesse <jjesse at gmail.com>:
>>> Good afternoon guys
>>> this has reared its head today again for me.  not able to connect to my wpa
>>> wireless.  Was working fine, but just stopped working today.
>>> keep on getting prompted for the password which ive verified is correct
>>Hi, I had problems with Karmic 9.10 with the broadcom card, too.
>>However, I discovered that If I use another kernel version, after
>>installing the broadcom driver, the card works. So, I connect to the
>>Internet with my wired connection, then I install the broadcom driver
>>with aptitude or apt-get, and finally I install a new kernel version.
>>When I install the new kernel, the driver is activated. Then, I reboot
>>and the driver works. I'm using now 2.6.31-14-generi, might be you
>>install a new kernel, then install the driver for the default version
>>of the kernel of Karmic.
>>I discovered another interesting thing: I was able to activate the
>>driver using jockey-kde from the live cd, and it works perfectly.
>>However after I install from the same live cd, I wasn't able to
>>activate it, and I got the same awful problem; I press activate in
>>jockey, and nothing happens.
>>Finally, I discovered that the problem is not with the broadcom driver
>>itself, I'm using now wicd insted of network manager of kde 4 that is
>>still buggy.
>>So, try a new kernel, try to use jockey-kde, try to go to
>>pool-restricted after install karmic and re-install the package from
>>broadcom, and finally install wicd. All that works.
> There is an item in the release notes about Jockey failing when there is no local package cache.  This is why it works in the live CD, but not after install until you connect via wired and check for updates.

I didn't know the why, thanks.

In the other hand, I don't know why the driver didn't work with the
kernel installed by default, and it works with other kernels. I need
to install a new kernel version, then the installed driver works, only
by installing and using  a new kernel. With the new one, the module is
loaded and configured properly.
There's no way to plug the laptop ( in this case the hardware with
this card ) to a wired network, install the broadcom driver, and get
it working.

I need to install the driver, install a new kernel, then I get the
driver ready to work. I guess there's some bug with the module
install, or the module itself.

After that, when I get the driver to work, and everything work
flawlessly. I'm using the driver with Karmic, and works without any
bug or problems with the speed/corruptions while sending/receiving
data. Some buggy instances of the driver present in the development
alpha/beta/pre-releases are gone.

Another important point is that when I solved the problems with the
driver, I still had problems with the Kde Network Manager. So I * need
* to install wicd to be able to connect to
password-protected/encrypted wireless connections.

> There's been some discussion about Jockey and Nvidia problems with different kernel versions on ubtuntu-devel.  I wonder if it affects wifi too?

Jockey doesn't work with this card after installing. Also, it's buggy
in the development releases, and it showed the same issues when I
tried both jockey-gtk and the kubuntu's version.

I tried kubuntu in several daily-iso versions when it was alpha, beta,
and also I tried ubuntu and xubuntu, and I got the same problem. It's
interesting to say that Kubuntu 9.04 worked out of the box, perfectly
with the exact same hardware, and I didn't need to install the driver
nor install wicd.

Last; I read somewhere that after installing Kubuuntu Karmic, if I
re-install the package present in pool restricted, it works. However
I'm not sure.

Sorry for this long mail, however there's lots of data to comment and
inform, because I worked a lot with this issue in different hardware,
and I tried different things, and some worked and other not.

I'm able to give you guys all the information you might need, because
I'm following this bugs since Kubuntu/Ubuntu 9.04, and I found
different solutions depending of the release, the kernel and so on.


> Scott K
> --
> kubuntu-devel mailing list
> kubuntu-devel at lists.ubuntu.com
> Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-devel

More information about the kubuntu-devel mailing list