Possible bug / security issue with klaptopdaemon package

Ravi Joganathan ohanzee at gmail.com
Wed Mar 30 12:32:35 CST 2005

Yesterday I downloaded and tried Kbuntu live preview[0] 5.04.  I tried to 
enable ACPI functionality accessible through "Control Centre"[1] and 
when I clicked on "Setup Helper Application" button the following warning
message appeared:

"The /usr/bin/klaptop_acpi_helper application does not seem to have the 
same size or checksum as when it was compiled we do NOT recommend you proceed
with making it setuid-root without further investigation"

Since /usr/bin/klaptop_acpi_helper is provided by klaptopdaemon package I ran:
$ md5sum -c -v /var/lib/dpkg/info/klaptopdaemon.md5sums 
All the files provided by this package passed the checksum verification.

I observed the same behaviour on Warty as well.  

Has anybodyelse seen this behaviour? 


[0] http://cdimage.ubuntu.com/kubuntu/releases/hoary/preview/hoary-live-i386.iso
[1] Control Centre => Power Control => ACPI Config Tab

More information about the kubuntu-devel mailing list