[Bug 1905341] [NEW] kdeconnect-app broken on Focal

Robie Basak 1905341 at bugs.launchpad.net
Tue Nov 24 00:05:45 UTC 2020


Public bug reported:

On a default Ubuntu (not Kubuntu) desktop install, kdeconnect-app does
not work at all. When running it from a terminal, it outputs:

QQmlApplicationEngine failed to load component
qrc:/qml/main.qml:93 Cannot assign object of type "DevicesModel" to property of type "QAbstractItemModel*" as the former is neither the same as the latter nor a sub-class of it.

And then hangs.

This is fixed in upstream release v1.4.1, specifically upstream commit
58a400a.

Groovy and Hirsute are not affected.

** Affects: kdeconnect (Ubuntu)
     Importance: Undecided
         Status: Fix Released

** Affects: kdeconnect (Ubuntu Focal)
     Importance: High
         Status: Triaged

** Also affects: kdeconnect (Ubuntu Focal)
   Importance: Undecided
       Status: New

** Changed in: kdeconnect (Ubuntu Focal)
       Status: New => Triaged

** Changed in: kdeconnect (Ubuntu Focal)
   Importance: Undecided => High

** Changed in: kdeconnect (Ubuntu)
       Status: New => Fix Released

-- 
You received this bug notification because you are a member of Kubuntu
Bugs, which is subscribed to kdeconnect in Ubuntu.
https://bugs.launchpad.net/bugs/1905341

Title:
  kdeconnect-app broken on Focal

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/kdeconnect/+bug/1905341/+subscriptions



More information about the kubuntu-bugs mailing list