[Bug 1849084] Re: Freeze on system-resume caused by kwin and amdgpu driver

Mike Lykov 1849084 at bugs.launchpad.net
Sun Nov 3 13:09:18 UTC 2019


Yes, this bug also affects me.
I upgrade from Kubuntu 19.04 with 5.0 kernel to 19.10 with 5.3 kernel, and got described behaviour:

1. On 5.0 there is no problems (if I boot it in 19.10)
2. on 5.3 with default settings - there is a black screen after try to resume.
3. If I choose XRender with 5.3 in plasma settings - no problems.

current kernel 5.3.0-19-generic #20-Ubuntu SMP Fri Oct 18 09:04:39
I have no traces of oops in log, journalctl -b -1 -k show only
kernel: PM: suspend entry (deep)
string before resume/hang at black screen.

current driver xserver-xorg-video-amdgpu 19.0.1-1ubuntu1 amd64  
xorg log
[    10.353] (II) AMDGPU(0): glamor X acceleration enabled on AMD RAVEN (DRM 3.33.0, 5.3.0-19-generic, LLVM 9.0.0)
[    10.353] (II) AMDGPU(0): glamor detected, initialising EGL layer.
[    10.353] (==) AMDGPU(0): TearFree property default: auto
[    10.353] (==) AMDGPU(0): VariableRefresh: disabled
[    10.353] (II) AMDGPU(0): KMS Pageflipping: enabled

notebook with attached monitor
[    10.396] (II) AMDGPU(0): EDID for output eDP
[    10.396] (II) AMDGPU(0): Manufacturer: BOE  Model: 6a5  Serial#: 0
[    10.396] (II) AMDGPU(0): Year: 2015  Week: 1
[    10.396] (II) AMDGPU(0): EDID Version: 1.4
[    10.396] (II) AMDGPU(0): Digital Display Input
[    10.396] (II) AMDGPU(0): 6 bits per channel
[    10.396] (II) AMDGPU(0): Digital interface is DisplayPort
[    10.397] (II) AMDGPU(0): EDID for output HDMI-A-0
[    10.397] (II) AMDGPU(0): Manufacturer: BNQ  Model: 801b  Serial#: 21573
[    10.397] (II) AMDGPU(0): Year: 2017  Week: 15
[    10.397] (II) AMDGPU(0): EDID Version: 1.3
[    10.397] (II) AMDGPU(0): Digital Display Input
[    10.398] (II) AMDGPU(0): Output eDP connected
[    10.398] (II) AMDGPU(0): Output HDMI-A-0 connected
[    10.398] (II) AMDGPU(0): Using spanning desktop for initial modes
[    10.398] (II) AMDGPU(0): Output eDP using initial mode 1366x768 +0+0
[    10.398] (II) AMDGPU(0): Output HDMI-A-0 using initial mode 2560x1440 +1366+0
[    10.399] (II) AMDGPU(0): [DRI2] Setup complete
[    10.399] (II) AMDGPU(0): [DRI2]   DRI driver: radeonsi
[    10.399] (II) AMDGPU(0): [DRI2]   VDPAU driver: radeonsi
[    10.533] (II) AMDGPU(0): Front buffer pitch: 15872 bytes
[    10.534] (II) AMDGPU(0): SYNC extension fences enabled
[    10.534] (II) AMDGPU(0): Present extension enabled
[    10.534] (==) AMDGPU(0): DRI3 enabled
[    10.534] (==) AMDGPU(0): Backing store enabled
[    10.534] (II) AMDGPU(0): Direct rendering enabled
[    10.541] (II) AMDGPU(0): Use GLAMOR acceleration.
[    10.541] (II) AMDGPU(0): Acceleration enabled
[    10.541] (==) AMDGPU(0): DPMS enabled
[    10.541] (==) AMDGPU(0): Silken mouse enabled
[    10.541] (II) AMDGPU(0): Set up textured video (glamor)

-- 
You received this bug notification because you are a member of Kubuntu
Bugs, which is subscribed to kwin in Ubuntu.
https://bugs.launchpad.net/bugs/1849084

Title:
  Freeze on system-resume caused by kwin and amdgpu driver

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/kwin/+bug/1849084/+subscriptions



More information about the kubuntu-bugs mailing list