[Bug 1778908] [NEW] 16.04 libtag dependancy issues

Dale dj_kaza at hotmail.com
Wed Jun 27 12:22:47 UTC 2018


Public bug reported:

This issue has come up from trying to install Mixxx from their official
LaunchPad host ppa and it appears to reference libtag1-vanilla, which
does appear to exist in 16.04 but I believe should be superseded by
libtag1v5-vanilla, yet it doesn't seem to recognise as such. As it then
can't be manually installed or the other removed I think there is a
deeper issue with this package than just Mixxx having the wrong one down
as a dependency.

This has been reported to the Mixxx developers on their forum about a
week ago but no official response as yet...

I've run this in a virtual box but there are multiple users who have
reported this on their main systems (at least four I've seen.)

osboxes at osboxes:~$ sudo apt-get update
[sudo] password for osboxes: 
Hit:1 http://security.ubuntu.com/ubuntu xenial-security InRelease
Hit:2 http://ppa.launchpad.net/mixxx/mixxx/ubuntu xenial InRelease                                                 
Hit:3 http://us.archive.ubuntu.com/ubuntu xenial InRelease                                                         
Hit:4 http://us.archive.ubuntu.com/ubuntu xenial-updates InRelease
Hit:5 http://us.archive.ubuntu.com/ubuntu xenial-backports InRelease
Reading package lists... Done                     
osboxes at osboxes:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
osboxes at osboxes:~$ sudo apt-get install mixxx
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 mixxx : Depends: libtag1-vanilla (>= 1.10-0ubuntu1~xenial0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
osboxes at osboxes:~$ sudo apt-get install libtag1-vanilla
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libcheese8 : Depends: gstreamer1.0-plugins-good (>= 0.11.0) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
osboxes at osboxes:~$ sudo apt-get install gstreamer1.0-plugins-good
Reading package lists... Done
Building dependency tree       
Reading state information... Done
gstreamer1.0-plugins-good is already the newest version (1.8.3-1ubuntu0.4).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
osboxes at osboxes:~$ sudo apt-get remove libtag1v5-vanilla 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 indicator-bluetooth : Depends: unity-control-center but it is not going to be installed or
                                gnome-control-center but it is not going to be installed or
                                ubuntu-system-settings but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
osboxes at osboxes:~$ sudo apt-get remove libtag1v5
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libcheese8 : Depends: gstreamer1.0-plugins-good (>= 0.11.0) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
osboxes at osboxes:~$ sudo apt-cache policy libtag1-vanilla 
libtag1-vanilla:
  Installed: (none)
  Candidate: 1.10-0ubuntu1~xenial0
  Version table:
     1.10-0ubuntu1~xenial0 500
        500 http://ppa.launchpad.net/mixxx/mixxx/ubuntu xenial/main amd64 Packages

** Affects: taglib (Ubuntu)
     Importance: Undecided
         Status: New

-- 
You received this bug notification because you are a member of Kubuntu
Bugs, which is subscribed to taglib in Ubuntu.
https://bugs.launchpad.net/bugs/1778908

Title:
  16.04 libtag dependancy issues

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/taglib/+bug/1778908/+subscriptions



More information about the kubuntu-bugs mailing list