[Bug 1167455] Re: Dead keys stop working fine in KDE apps after navigating through menu bar

Jorge Rodríguez López jorge.librerux at gmail.com
Wed Apr 10 18:48:58 UTC 2013


** Description changed:

  Accented letters (dead keys) stop working fine in KDE apps after
  navigating through menu bar's.
  
  When typing in the text area of KDE applications, the keyboard (with
  dead keys) work fine, but if you access the (classic) menu bar in the
  application window, dead keys may stop working fine.
  
  e.g. with English (US, international with dead keys) keyboard layout
    Press key "´" and "A", expected output= "á"
    output with ibus= "" (nothing)
    output with xim= "´a" (Dead keys are alive)
  
  Exceptions:
  
  - With widget Window Menubar no problem.
  - In Rekonk, with menu system like Chrome, no problem.
  
  Steps to follow:
  
  In KDE desktop...
  
  1º Check that you are using a keyboard layout with dead keys, if not, install and use one.
      System Settings > Input devices > keyboard > Layout > Configure layouts
      e.g. English (US, international with dead keys)
  
  2º Open a kde app, (e.g. kate)
  
  3º Write something to check that dead keys work well.
      In English, e.g. press "´" and "A" results in "á"
  
  4º Access of the menu bar in the application window and scroll through
  the options for 30 seconds or more.
  
- 5º If dead keys fail, change the focus (e.g. another window) and return
+ 5º Back to the editing area and write something to check that dead keys work well.
+     In English, e.g. press "´" and "A" results in "á"
+ 
+ 6º If dead keys fail, change the focus (e.g. another window) and return
  to kate, dead keys work again.
  
  Testing:
  
  Tested in different computers.
  Tested in Debian, kubuntu (13.04, 12.10, 12.04), OpenSuse.
  Tested with desktop effects enabled and disabled
  Tested in Kate, Dolphin, Kontact, Amarok, Agregator...
  Tested in KDE 4.10, 4.9, 4.8 and... 4.4.5
  Tested with free and privative drivers
  Tested with Spanish, Portuguese and English keyboard layouts
  Tested in installed system and live-cd.
  Tested navigating menus with mouse and keyboard
  Tested with IBus and XIM input method
  
  Comment:
  
  If this bug is not resolved, please, the Kubuntu 13.04 release with widget Window Menubar be default.
  I apologize for my English.
  
  ProblemType: Bug
  DistroRelease: Ubuntu 13.04
  Package: plasma-desktop 4:4.10.2-0ubuntu1
  ProcVersionSignature: Ubuntu 3.8.0-17.27-generic 3.8.6
  Uname: Linux 3.8.0-17-generic x86_64
  ApportVersion: 2.9.2-0ubuntu5
  Architecture: amd64
  Date: Wed Apr 10 18:59:45 2013
  ExecutablePath: /usr/bin/plasma-desktop
  InstallationDate: Installed on 2013-04-03 (6 days ago)
  InstallationMedia: Kubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130402.1)
  MarkForUpload: True
  ProcEnviron:
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=<set>
   LANG=es_ES.UTF-8
   SHELL=/bin/bash
  SourcePackage: kde-workspace
  UpgradeStatus: No upgrade log present (probably fresh install)

-- 
You received this bug notification because you are a member of Kubuntu
Bugs, which is subscribed to kde-workspace in Ubuntu.
https://bugs.launchpad.net/bugs/1167455

Title:
  Dead keys stop working fine in KDE apps after navigating through menu
  bar

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/kde-workspace/+bug/1167455/+subscriptions



More information about the kubuntu-bugs mailing list