[Bug 924300] [NEW] bluedevil crashes but there is no debugging symbols package.

nonadrift news at muppet.plus.com
Tue Jan 31 13:55:42 UTC 2012


Public bug reported:

I have a Tunestage RX bluetooth audio receiver which I use to play music
from my laptop. It has an annoying bug where if the audio stream is
suspended it loses the connection somehow and you have to reconnect.
Blueman on Gnome manages to handle this and not crash so I just have to
reconnect, but Bluedevil on KDE cannot and crashes.

I tried to generate a bug report with the kcrash tool but cannot find
debugging symbols for Bluedevil. Looked in synaptic, there is no
bluedevil-dbg or anything similar.

I know the fault is really with the Tunestage RX, but parts of KDE
should not crash when external devices are flaky, in my opinion. Ideally
Bluez or Bluedevil should know about the problem and just send silence
instead of suspending the audio stream but maybe that is asking too much
:)

Thread 1 (Thread 0xb7832710 (LWP 3011)):
 [KCrash Handler]
 #7 0x07e95035 in BlueDevil::Adapter::unregisterAgent(QString const&) () from /usr/lib/libbluedevil.so.1
 #8 0x07d2fd26 in ?? () from /usr/lib/kde4/kded_bluedevil.so
 #9 0x07d2f670 in ?? () from /usr/lib/kde4/kded_bluedevil.so
 #10 0x07d2f6b2 in ?? () from /usr/lib/kde4/kded_bluedevil.so
 #11 0x00f835f3 in qDeleteInEventHandler (o=0xa1c3280) at kernel/qobject.cpp:3986
 #12 0x00f88b80 in QObject::event (this=0xa1c3280, e=0xa1da1e8) at kernel/qobject.cpp:1200
 #13 0x06149d54 in notify_helper (e=0xa1da1e8, receiver=0xa1c3280, this=0x9fca518) at kernel/qapplication.cpp:4483

Ubuntu 11.10
bluedevil 1.2.1-0ubuntu1

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: bluedevil 1.2.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-15.26-generic 3.0.13
Uname: Linux 3.0.0-15-generic i686
ApportVersion: 1.23-0ubuntu4
Architecture: i386
Date: Tue Jan 31 13:46:58 2012
EcryptfsInUse: Yes
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: bluedevil
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: bluedevil (Ubuntu)
     Importance: Undecided
         Status: New


** Tags: apport-bug i386 oneiric

-- 
You received this bug notification because you are a member of Kubuntu
Bugs, which is subscribed to bluedevil in Ubuntu.
https://bugs.launchpad.net/bugs/924300

Title:
  bluedevil crashes but there is no debugging symbols package.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/bluedevil/+bug/924300/+subscriptions



More information about the kubuntu-bugs mailing list