[Bug 918765] [NEW] package libqtcore4 4:4.8.0-1ubuntu1 failed to install/upgrade: conffile './etc/xdg/Trolltech.conf' is not in sync with other instances of the same package

Romanos Dodopoulos 918765 at bugs.launchpad.net
Thu Jan 19 16:04:53 UTC 2012


Public bug reported:

I try to install skype-32bit from package:

-----------------------------------------------------------------------------------------------------
:~$ sudo dpkg -i Downloads/skype-ubuntu_2.2.0.35-1_i386.deb 
[sudo] password for romanos: 
Selecting previously unselected package skype:i386.
(Reading database ... 219104 files and directories currently installed.)
Unpacking skype:i386 (from .../skype-ubuntu_2.2.0.35-1_i386.deb) ...
(Noting disappearance of skype, which has been completely replaced.)
dpkg: dependency problems prevent configuration of skype:i386:
 skype:i386 depends on libqt4-dbus (>= 4.4.3); however:
  Package libqt4-dbus:i386 is not installed.
 skype:i386 depends on libqt4-network (>= 4.4.3); however:
  Package libqt4-network:i386 is not installed.
 skype:i386 depends on libqtcore4 (>= 4.4.3); however:
  Package libqtcore4:i386 is not installed.
 skype:i386 depends on libqtgui4 (>= 4.4.3); however:
  Package libqtgui4:i386 is not installed.
 skype:i386 depends on libxss1; however:
  Package libxss1:i386 is not installed.
 skype:i386 depends on libxv1; however:
  Package libxv1:i386 is not installed.
dpkg: error processing skype:i386 (--install):
 dependency problems - leaving unconfigured
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for gnome-menus ...
Processing triggers for desktop-file-utils ...
Errors were encountered while processing:
 skype:i386
-----------------------------------------------------------------------------------------------------

-----------------------------------------------------------------------------------------------------
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 skype:i386 : Depends: libqt4-dbus:i386 (>= 4.4.3) but it is not installed
              Depends: libqt4-network:i386 (>= 4.4.3) but it is not installed
              Depends: libqtcore4:i386 (>= 4.4.3) but it is not installed
              Depends: libqtgui4:i386 (>= 4.4.3) but it is not installed
              Depends: libxss1:i386 but it is not installed
              Depends: libxv1:i386 but it is not installed
E: Unmet dependencies. Try using -f.
-----------------------------------------------------------------------------------------------------

Then I run:

-----------------------------------------------------------------------------------------------------
romanos at linux:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libatk1.0-0:i386 libxfixes3:i386 libxcomposite1:i386 libldap-2.4-2:i386
  libroken18-heimdal:i386 libidn11:i386 libnss3:i386 nspluginwrapper libasn1-8-heimdal:i386
  libnspr4-0d:i386 libcairo2:i386 libgssapi3-heimdal:i386 libgdk-pixbuf2.0-0:i386
  flashplugin-downloader:i386 libwind0-heimdal:i386 libpixman-1-0:i386 libcurl3:i386
  libxinerama1:i386 nspluginviewer:i386 libxft2:i386 libhcrypto4-heimdal:i386 libnspr4:i386
  libhx509-5-heimdal:i386 libheimbase1-heimdal:i386 libjasper1:i386 libsasl2-2:i386
  libpango1.0-0:i386 libheimntlm0-heimdal:i386 libxdamage1:i386 libxcb-render0:i386
  librtmp0:i386 libxcursor1:i386 libxcb-shm0:i386 libsasl2-modules:i386 libxrandr2:i386
  libnss3-1d:i386 libsqlite3-0:i386 libgtk2.0-0:i386 libkrb5-26-heimdal:i386
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libaudio2:i386 liblcms1:i386 libmng1:i386 libmysqlclient18:i386 libqt4-dbus:i386
  libqt4-declarative:i386 libqt4-network:i386 libqt4-script:i386 libqt4-sql:i386
  libqt4-sql-mysql:i386 libqt4-xml:i386 libqt4-xmlpatterns:i386 libqtcore4:i386 libqtgui4:i386
  libxss1:i386 libxv1:i386
Suggested packages:
  nas:i386 liblcms-utils:i386 libqt4-declarative-folderlistmodel:i386
  libqt4-declarative-gestures:i386 libqt4-declarative-particles:i386
  libqt4-declarative-shaders:i386 qt4-qmlviewer:i386 libqt4-dev:i386 qt4-qtconfig:i386
The following NEW packages will be installed:
  libaudio2:i386 liblcms1:i386 libmng1:i386 libmysqlclient18:i386 libqt4-dbus:i386
  libqt4-declarative:i386 libqt4-network:i386 libqt4-script:i386 libqt4-sql:i386
  libqt4-sql-mysql:i386 libqt4-xml:i386 libqt4-xmlpatterns:i386 libqtcore4:i386 libqtgui4:i386
  libxss1:i386 libxv1:i386
0 upgraded, 16 newly installed, 0 to remove and 3 not upgraded.
1 not fully installed or removed.
Need to get 1,327 kB/11.4 MB of archives.
After this operation, 41.5 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://gr.archive.ubuntu.com/ubuntu/ precise/main libaudio2 i386 1.9.3-1 [58.6 kB]
Get:2 http://gr.archive.ubuntu.com/ubuntu/ precise/main liblcms1 i386 1.19.dfsg-1ubuntu3 [109 kB]
Get:3 http://gr.archive.ubuntu.com/ubuntu/ precise/main libmng1 i386 1.0.10-3 [217 kB]
Get:4 http://gr.archive.ubuntu.com/ubuntu/ precise/main libxss1 i386 1:1.2.1-2 [8,604 B]
Get:5 http://gr.archive.ubuntu.com/ubuntu/ precise/main libxv1 i386 2:1.0.6-2 [12.0 kB]
Get:6 http://gr.archive.ubuntu.com/ubuntu/ precise/main libmysqlclient18 i386 5.5.17-4ubuntu6 [922 kB]
Fetched 1,327 kB in 1s (874 kB/s)         
Selecting previously unselected package libqtcore4:i386.
(Reading database ... 219240 files and directories currently installed.)
Unpacking libqtcore4:i386 (from .../libqtcore4_4%3a4.8.0-1ubuntu1_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libqtcore4_4%3a4.8.0-1ubuntu1_i386.deb (--unpack):
 conffile './etc/xdg/Trolltech.conf' is not in sync with other instances of the same package
Selecting previously unselected package libqt4-xml:i386.
Unpacking libqt4-xml:i386 (from .../libqt4-xml_4%3a4.8.0-1ubuntu1_i386.deb) ...
Selecting previously unselected package libqt4-dbus:i386.
Unpacking libqt4-dbus:i386 (from .../libqt4-dbus_4%3a4.8.0-1ubuntu1_i386.deb) ...
Selecting previously unselected package libqt4-network:i386.
Unpacking libqt4-network:i386 (from .../libqt4-network_4%3a4.8.0-1ubuntu1_i386.deb) ...
Selecting previously unselected package libaudio2:i386.
Unpacking libaudio2:i386 (from .../libaudio2_1.9.3-1_i386.deb) ...
Selecting previously unselected package liblcms1:i386.
Unpacking liblcms1:i386 (from .../liblcms1_1.19.dfsg-1ubuntu3_i386.deb) ...
Selecting previously unselected package libmng1:i386.
Unpacking libmng1:i386 (from .../libmng1_1.0.10-3_i386.deb) ...
Selecting previously unselected package libqt4-script:i386.
Unpacking libqt4-script:i386 (from .../libqt4-script_4%3a4.8.0-1ubuntu1_i386.deb) ...
Selecting previously unselected package libqt4-sql:i386.
Unpacking libqt4-sql:i386 (from .../libqt4-sql_4%3a4.8.0-1ubuntu1_i386.deb) ...
Selecting previously unselected package libqt4-xmlpatterns:i386.
Unpacking libqt4-xmlpatterns:i386 (from .../libqt4-xmlpatterns_4%3a4.8.0-1ubuntu1_i386.deb) ...
Selecting previously unselected package libqt4-declarative:i386.
Unpacking libqt4-declarative:i386 (from .../libqt4-declarative_4%3a4.8.0-1ubuntu1_i386.deb) ...
Selecting previously unselected package libqtgui4:i386.
Unpacking libqtgui4:i386 (from .../libqtgui4_4%3a4.8.0-1ubuntu1_i386.deb) ...
Selecting previously unselected package libxss1:i386.
Unpacking libxss1:i386 (from .../libxss1_1%3a1.2.1-2_i386.deb) ...
Selecting previously unselected package libxv1:i386.
Unpacking libxv1:i386 (from .../libxv1_2%3a1.0.6-2_i386.deb) ...
Selecting previously unselected package libmysqlclient18:i386.
Unpacking libmysqlclient18:i386 (from .../libmysqlclient18_5.5.17-4ubuntu6_i386.deb) ...
Selecting previously unselected package libqt4-sql-mysql:i386.
Unpacking libqt4-sql-mysql:i386 (from .../libqt4-sql-mysql_4%3a4.8.0-1ubuntu1_i386.deb) ...
Errors were encountered while processing:
 /var/cache/apt/archives/libqtcore4_4%3a4.8.0-1ubuntu1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
-----------------------------------------------------------------------------------------------------

And I get the window to report the error. (Maybe 2 bugs because the
window to send report appeared 2 times )

I still try to install skype since the upgrade removed it.

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: libqtcore4 4:4.8.0-1ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-9.16-generic 3.2.1
Uname: Linux 3.2.0-9-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
Date: Thu Jan 19 17:51:45 2012
DpkgTerminalLog:
 Unpacking libqtcore4:i386 (from .../libqtcore4_4%3a4.8.0-1ubuntu1_i386.deb) ...
 dpkg: error processing /var/cache/apt/archives/libqtcore4_4%3a4.8.0-1ubuntu1_i386.deb (--unpack):
  conffile './etc/xdg/Trolltech.conf' is not in sync with other instances of the same package
DuplicateSignature:
 Unpacking libqtcore4:i386 (from .../libqtcore4_4%3a4.8.0-1ubuntu1_i386.deb) ...
 dpkg: error processing /var/cache/apt/archives/libqtcore4_4%3a4.8.0-1ubuntu1_i386.deb (--unpack):
  conffile './etc/xdg/Trolltech.conf' is not in sync with other instances of the same package
ErrorMessage: conffile './etc/xdg/Trolltech.conf' is not in sync with other instances of the same package
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20111129.1)
SourcePackage: qt4-x11
Title: package libqtcore4 4:4.8.0-1ubuntu1 failed to install/upgrade: conffile './etc/xdg/Trolltech.conf' is not in sync with other instances of the same package
UpgradeStatus: No upgrade log present (probably fresh install)
modified.conffile..etc.xdg.Trolltech.conf:
 [qt]
 4.8\libraryPath=/usr/lib/kde4/plugins
mtime.conffile..etc.xdg.Trolltech.conf: 2012-01-10T12:15:46

** Affects: qt4-x11 (Ubuntu)
     Importance: Undecided
         Status: New


** Tags: amd64 apport-package need-duplicate-check precise

-- 
You received this bug notification because you are a member of Kubuntu
Bugs, which is subscribed to qt4-x11 in Ubuntu.
https://bugs.launchpad.net/bugs/918765

Title:
  package libqtcore4 4:4.8.0-1ubuntu1 failed to install/upgrade:
  conffile './etc/xdg/Trolltech.conf' is not in sync with other
  instances of the same package

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/qt4-x11/+bug/918765/+subscriptions



More information about the kubuntu-bugs mailing list