[Bug 928009] [NEW] Kubuntu missing someKDE API 4.6 include files

Happy 928009 at bugs.launchpad.net
Tue Feb 7 03:22:06 UTC 2012


Public bug reported:

Specifically, Kubuntu seems to be missing some /usr/include/nepomuk
files.

I'm using Kubuntu (KDE 4.8, based on Kubuntu Oneiric with Kubuntu PPAs added - apt sources.list attached)
I have what I think are all the relevant development packages installed (kdelibs5-dev,  kdesdk, etc)

When trying to compile code to use Nepomuk queries, I get this error:
  fatal error: nepomuk/simpleresource.h: No such file or directory

'simpleresource.h' is part of the KDE API as at version 4.6 as can be seen here:
  http://api.kde.org/4.6-api/kdebase-runtime-apidocs/nepomuk/html/simpleresource_8h.html

Example code that uses this KDE API would be such as:
  http://trueg.wordpress.com/2012/01/28/something-way-less-dry-tv-shows/

This would seem to be a packaging bug?

Apt sources.list (with irrelevant stuff removed)

deb http://au.archive.ubuntu.com/ubuntu/ oneiric main restricted
deb-src http://au.archive.ubuntu.com/ubuntu/ oneiric main restricted

deb http://au.archive.ubuntu.com/ubuntu/ oneiric-updates main restricted
deb-src http://au.archive.ubuntu.com/ubuntu/ oneiric-updates main restricted

deb http://au.archive.ubuntu.com/ubuntu/ oneiric universe
deb-src http://au.archive.ubuntu.com/ubuntu/ oneiric universe
deb http://au.archive.ubuntu.com/ubuntu/ oneiric-updates universe
deb-src http://au.archive.ubuntu.com/ubuntu/ oneiric-updates universe

deb http://au.archive.ubuntu.com/ubuntu/ oneiric multiverse
deb-src http://au.archive.ubuntu.com/ubuntu/ oneiric multiverse
deb http://au.archive.ubuntu.com/ubuntu/ oneiric-updates multiverse
deb-src http://au.archive.ubuntu.com/ubuntu/ oneiric-updates multiverse

deb http://au.archive.ubuntu.com/ubuntu/ oneiric-backports main restricted universe multiverse                                                                              
                                                                                                                                                                            
deb http://security.ubuntu.com/ubuntu oneiric-security main restricted                                                                                                      
deb-src http://security.ubuntu.com/ubuntu oneiric-security main restricted                                                                                                  
deb http://security.ubuntu.com/ubuntu oneiric-security universe
deb-src http://security.ubuntu.com/ubuntu oneiric-security universe
deb http://security.ubuntu.com/ubuntu oneiric-security multiverse
deb-src http://security.ubuntu.com/ubuntu oneiric-security multiverse

deb http://archive.canonical.com/ubuntu oneiric partner

deb http://extras.ubuntu.com/ubuntu oneiric main
deb http://au.archive.ubuntu.com/ubuntu/ oneiric-proposed restricted main multiverse universe
deb-src http://extras.ubuntu.com/ubuntu oneiric main

deb-src http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu oneiric
main # disabled on upgrade to oneiric

** Affects: kubuntu-meta (Ubuntu)
     Importance: Undecided
         Status: New

-- 
You received this bug notification because you are a member of Kubuntu
Bugs, which is subscribed to kubuntu-meta in Ubuntu.
https://bugs.launchpad.net/bugs/928009

Title:
  Kubuntu missing someKDE API 4.6 include files

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/kubuntu-meta/+bug/928009/+subscriptions



More information about the kubuntu-bugs mailing list