[Bug 927637] Re: upgrade failure: qdbus and libqt4-dbus cyclic dependency

Launchpad Bug Tracker 927637 at bugs.launchpad.net
Mon Feb 6 21:20:12 UTC 2012


This bug was fixed in the package qt4-x11 - 4:4.8.0-1ubuntu5

---------------
qt4-x11 (4:4.8.0-1ubuntu5) precise; urgency=low

  [ Martin Pitt ]
  * debian/control: Drop qdbus dependency of libqt4-dbus to a Recommends. The
    library does not actually need qdbus, and this is a cyclic dependency
    which breaks upgrades. (LP: #927637)

  [ Jonathan Riddell ]
  * Add kubuntu_29_window_shaping_fix.diff from
    http://qt.gitorious.org/qt/qt/commit/21713e04160ee285c831fedd1f3c7b8
    ce0aba681 take window shape into account in findRealWindow,
    LP: #926129
 -- Jonathan Riddell <jriddell at ubuntu.com>   Mon, 06 Feb 2012 19:39:15 +0000

** Changed in: qt4-x11 (Ubuntu Precise)
       Status: Fix Committed => Fix Released

-- 
You received this bug notification because you are a member of Kubuntu
Bugs, which is subscribed to qt4-x11 in Ubuntu.
https://bugs.launchpad.net/bugs/927637

Title:
  upgrade failure: qdbus and libqt4-dbus cyclic dependency

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/qt4-x11/+bug/927637/+subscriptions



More information about the kubuntu-bugs mailing list