[Bug 799202] [NEW] wacom stylus jumps with latest xserver-xorg-core

Launchpad Bug Tracker 799202 at bugs.launchpad.net
Mon Sep 26 07:44:48 UTC 2011


You have been subscribed to a public bug:

Wacom input jumps while drawing with xserver-xorg-core version 2:1.10.1-1ubuntu1.1
It is working correctly with version 2:1.10.1-1ubuntu1.

This issue is somehow related to issue #762938 (no pressure sensitivity
with wacom tablet).

A fix for pressure sensitivity was proposed by Chase Douglas in the
utouch-team/unstable ppa.

Using the official ubuntu Qt version, stylus position works fine, but pressure sensitivity does not work.
When using Chase Douglas's ppa, pressure works fine, but the cursor position jumps while drawing.

Note that the issue only happens when using the wacom stylus that is
"pressure sensitive", not when using the wacom mouse that has no
pressure.

As previously said, the "jumping cursor" issue disappears if I downgrade
xserver-xorg-core to version 1.10.1-1ubuntu1

The bug can be seen in Krita, when drawing a line, the cursor jumps, a picture showing the problem can be seen here:
https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/799202/+attachment/2174502/+files/pressure_bug.png

I can reproduce the issue on a tablet pc with touch sensitive screen and
a  desktop pc with usb Wacom tablet.

At least 2 other users are having the same issue, see:
https://bugs.launchpad.net/ubuntu/+source/pencil/+bug/762938

Using Ubuntu 11.04

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xserver-xorg-core 2:1.10.1-1ubuntu1.1
ProcVersionSignature: Ubuntu 2.6.38-10.44-generic-pae 2.6.38.7
Uname: Linux 2.6.38-10-generic-pae i686
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: kwin
Date: Sat Jun 18 18:44:38 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: kubuntu
DkmsStatus:
 virtualbox-ose, 4.0.4, 2.6.38-9-generic-pae, i686: installed
 virtualbox-ose, 4.0.4, 2.6.38-10-generic-pae, i686: installed
GraphicsCard:
 Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:215a]
InstallationMedia: Kubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110202)
MachineType: LENOVO 2985FJG
ProcEnviron:
 LANGUAGE=
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-10-generic-pae root=UUID=1524b654-818e-4d16-807f-4e0db5f1b26f ro quiet splash vt.handoff=7
ProcKernelCmdLine_: BOOT_IMAGE=/boot/vmlinuz-2.6.38-10-generic-pae root=UUID=1524b654-818e-4d16-807f-4e0db5f1b26f ro quiet splash vt.handoff=7
Renderer: Unknown
SourcePackage: xorg-server
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/15/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 6QET53WW (1.23 )
dmi.board.name: 2985FJG
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6QET53WW(1.23):bd09/15/2010:svnLENOVO:pn2985FJG:pvrThinkPadX201Tablet:rvnLENOVO:rn2985FJG:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 2985FJG
dmi.product.version: ThinkPad X201 Tablet
dmi.sys.vendor: LENOVO
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3.1
version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A

** Affects: qt4-x11 (Ubuntu)
     Importance: Medium
     Assignee: Chase Douglas (chasedouglas)
         Status: In Progress


** Tags: apport-bug i386 kubuntu natty patch
-- 
wacom stylus jumps with latest xserver-xorg-core
https://bugs.launchpad.net/bugs/799202
You received this bug notification because you are a member of Kubuntu Bugs, which is subscribed to qt4-x11 in Ubuntu.



More information about the kubuntu-bugs mailing list