[Bug 855436] [NEW] Sync strigi 0.7.6-1 (main) from Debian unstable (main)

Fathi Boudra fathi.boudra at linaro.org
Wed Sep 21 10:46:27 UTC 2011


Public bug reported:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

 affects ubuntu/strigi
 status new
 importance wishlist
 subscribe ubuntu-sponsors
 done

Please sync strigi 0.7.6-1 (main) from Debian unstable (main)

Explanation of the Ubuntu delta and why it can be dropped:
  * Stop building the deskbar-plugins-strigi package. The deskbar-applet
    binary will be removed for the oneiric release. LP: #831219.
  * Switch to dh_python2:
    - Drop python-support from debian/rules and set minimum python version to
      2.6.6-3~
    - Update debian/rules to build --with python2 and override dh_python2
      instead of dh_pysupport
  * Update symbols to fix FTBFS (LP: #765910)
  * No change upload to rebuild against new libexiv
  * Final symbols patch (for amd64)
  * Update symbols file. A newer GCC version must have changed some of the
    symbols slightly.
  * Rebuild to pick up a newer libexiv2 dependency since libexiv2-6 is NBS

Strigi 0.7.6-1 contains up-to-date symbols files and drop the
deskbar-plugins-strigi package, making Ubuntu changes obsolete.
In addition, this package fixes: LP:852546 and LP:854330.

Changelog entries since current oneiric version 0.7.2-1ubuntu6:

strigi (0.7.6-1) unstable; urgency=low

  * New upstream release.
  * Drop debian/patches/01_remove_FindQt4.cmake_local_copy.diff - merged
    upstream.
  * Update debian/compat: bump to 8.
  * Update debian/control:
    - bump debehlper to 8.1.3~.
    - add dbus-x11, libavcodec-dev, libavformat-dev, libpostproc-dev and
      libswscale-dev build dependencies.
    - drop pkg-kde-tools build dependency - not used.
    - drop python and python-support build dependencies.
    - bump Standard-Version to 3.9.2, use Breaks instead of Conflicts.
    - drop deskbar-plugins-strigi package.
  * Drop debian/libstreams0.docs file - not used anymore.
  * Update debian/*-dev.install files.
  * Update debian/rules:
    - drop useless override_dh_{pysupport, strip}.
    - remove unused commented lines.
  * Update symbols files.

 -- Fathi Boudra <fabo at debian.org>  Tue, 20 Sep 2011 08:50:25 +0300

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.18 (GNU/Linux)

iJwEAQECAAYFAk55v3gACgkQjPU19mqlcvd1yAP/VQTTL8UDDTtgxG08GnKR0gbG
ExF9Ft4bMWoStIwvLmhFDReqp2dhWzbHGk+7FyuFxMyiihQKyhyzK8yztQEe6Rph
PyHsgJDqAPyAgXqiCfd4hqYueW5KXc0OXswfxLwyDx8f3eoWUDyQ6ZLfJoSzAMte
WGxe3dlC2GowNNXm4+o=
=JbkD
-----END PGP SIGNATURE-----

** Affects: strigi (Ubuntu)
     Importance: Wishlist
         Status: New

-- 
You received this bug notification because you are a member of Kubuntu
Bugs, which is subscribed to strigi in Ubuntu.
https://bugs.launchpad.net/bugs/855436

Title:
  Sync strigi 0.7.6-1 (main) from Debian unstable (main)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/strigi/+bug/855436/+subscriptions



More information about the kubuntu-bugs mailing list