[Bug 859075] Re: Oneiric does not shutdown

Clint Byrum clint at fewbar.com
Wed Oct 19 06:43:23 UTC 2011


Excerpts from Stevan Kew Ell's message of Wed Oct 19 05:58:28 UTC 2011:
> @Clint Byrum (clint-fewbar)  Message 20
> 
> I have done as you ask, and I can get consistent failures and successes
> which may help.  I am running Xubuntu and carried out all these tests
> using the shutdown button on the desktop.  /etc/default/halt is set to
> poweroff.
> 
> When shutdown powers off the machine, I can confirm that it passes the
> following settings to halt:-
> 
> halt -d -f -i -p -h
> 
> I tried this on five occasions and operation is consistent, as long as
> you boot, and then immediately shut down.  However, if you leave the
> machine for a few minutes, then the shut down process does not get very
> far at all.  It hangs on:-
> 
> Killing all running processes.....
> 
> which is quite early in the shutdown process, and therefore the issue is
> not with the halt command but with the shutdown process itself.  That's
> an assumption on my art as I don't really understand the way upstart
> handles this.
> 
> I assume that shutting down immediately means upstart is still running,
> while leaving it a few minutes means upstart finishes its processes.
> 
> I tried this on half a dozen occasions, leaving the machine for 3
> minutes and get consistent results.
> 
> I hope this helps.
> 

That is fairly interesting, but may be a red herring.

The code that prints that out basically just runs killall5 -9 with any pids
still running as arguments. After that it will exit, so I suspect the
problem is further down.

There are quite a few scripts between sendsigs and halt..

lrwxrwxrwx 1 root root  18 2010-10-22 13:47 S20sendsigs -> ../init.d/sendsigs
lrwxrwxrwx 1 root root  17 2010-10-22 13:47 S30urandom -> ../init.d/urandom
lrwxrwxrwx 1 root root  22 2010-10-22 13:47 S31umountnfs.sh -> ../init.d/umountnfs.sh
lrwxrwxrwx 1 root root  20 2011-07-14 13:34 S35networking -> ../init.d/networking
lrwxrwxrwx 1 root root  18 2010-10-22 13:47 S40umountfs -> ../init.d/umountfs
lrwxrwxrwx 1 root root  20 2011-07-21 13:55 S48cryptdisks -> ../init.d/cryptdisks
lrwxrwxrwx 1 root root  26 2011-07-21 13:55 S59cryptdisks-early -> ../init.d/cryptdisks-early
lrwxrwxrwx 1 root root  20 2010-10-22 13:47 S60umountroot -> ../init.d/umountroot
lrwxrwxrwx 1 root root  14 2010-10-22 13:47 S90halt -> ../init.d/halt

Would be helpful to mod them all with 'set -x' so we can see what the
last command is before the system fails to shut down.

-- 
You received this bug notification because you are a member of Kubuntu
Bugs, which is subscribed to kde-workspace in Ubuntu.
https://bugs.launchpad.net/bugs/859075

Title:
  Oneiric does not shutdown

To manage notifications about this bug go to:
https://bugs.launchpad.net/upstart/+bug/859075/+subscriptions



More information about the kubuntu-bugs mailing list