[Bug 779840] [NEW] Kexi: No menus show up when using dbusmenu

Jaroslaw Staniek 779840 at bugs.launchpad.net
Mon May 9 10:59:29 UTC 2011


On 9 May 2011 12:37, Antonis Kanouras <antonis+launchpad at metadosis.gr> wrote:
> Public bug reported:
>
> Binary package hint: koffice
>
> As the title says, when using dbusmenu Kexi only shows a File > Close
> menu.
>
> Kexi is still using libqt4-qt3support, which may be the reason for this
> bug.

Hi Antonis,
Thanks for the report.
Qt3Support is not the reason. Kexi does not use menu at all but tabbed
toolbar [1], which does display with dbus menu or other non-native
menus. First thing to add would be "about application", "help" items
to the menu.

Kexi is still functional since it always display the tabbed toolbar.
It is up to discussion how the menu would be added and how that would
look, since the the menu is dynamic, it has elements appearing
depending on in what mode Kexi is executed, and the contents of each
tab is not linear (vertical) but grouped.

[1] http://www.kdedevelopers.org/node/2955

-- 
regards / pozdrawiam, Jaroslaw Staniek
 http://www.linkedin.com/in/jstaniek
 Kexi & Calligra (kexi-project.org, identi.ca/kexi, calligra-suite.org)
 KDE Software Development Platform on MS Windows (windows.kde.org)

-- 
You received this bug notification because you are a member of Kubuntu
Bugs, which is subscribed to koffice in Ubuntu.
https://bugs.launchpad.net/bugs/779840

Title:
  Kexi: No menus show up when using dbusmenu



More information about the kubuntu-bugs mailing list