[Bug 707794] Re: libqt4-opengl on armel should be compiled with OpenGL ES 2.x support

Ricardo Salveti rsalveti at rsalveti.net
Tue Feb 1 05:06:58 UTC 2011


>From Main, we have the following problems:
1 - avogadro: uses OpenGL and libqt4-opengl, and as a result it'll have symbols collision and the build will fail (no easy solution);
2 - kdeedu: need to remove Kalzium, as it uses avogadro and libqt4-opengl;
3 - kdegames: need to remove OpenGL support, and as a side effect Kubrick will not be built and KSudoku will not have Roxdoku support;
4 - kipi-plugins: need to remove OpenGL support;
5 - koffice: need to remove GLEW support;

And in general all packages that use libqt4-opengl with GLEW or normal
OpenGL, will fail to build. For those packages the solution would be to
remove OpenGL support, when possible.

-- 
You received this bug notification because you are a member of Kubuntu
Bugs, which is subscribed to qt4-x11 in ubuntu.
https://bugs.launchpad.net/bugs/707794

Title:
  libqt4-opengl on armel should be compiled with OpenGL ES 2.x support




More information about the kubuntu-bugs mailing list