[Bug 656195] Re: kdevelop crashes

Launchpad Bug Tracker 656195 at bugs.launchpad.net
Fri Oct 22 15:00:27 UTC 2010


This bug was fixed in the package kde4libs - 4:4.5.2a-0ubuntu1

---------------
kde4libs (4:4.5.2a-0ubuntu1) natty; urgency=low

  [ Rohan Garg ]
  * Merge with Debian git remaining changes:
    - no build-dep on libaspell-dev
    - no build-dep on libfam-dev
    - no install kspell_aspell.desktop and kspell_aspell.so
    - kdelibs5-dev do not install preparetips
    - DEB_CMAKE_EXTRA_FLAGS += -DKDESU_USE_SUDO_DEFAULT=true
    - DEB_FIXPERMS_EXCLUDE := /usr/lib/kde4/libexec/fileshareset
    - binary-install/kdelibs5-data:: rule (build-dep on sharutils)
      and copy over debian/icons
    - don't Recommend on kaboom
    - set export KUBUNTU_DESKTOP_POT=kdelibs
    - install usr/share/locale/all_languages in kdelibs5-data.install
    - don't add 20_use_dejavu_as_default_font

  [ Alessandro Ghersi ]
  - Merge a bit more with Debian
  - Drop libkutils4.symbols
  - kdelibs5-data.lintian-overrides, installgen: kde/HTML -> kde/HTML4
  - drop .gitattributes
  - Update KUBUNTU-DEBIAN-DIFFERENCES
  - Update patches with Debian
  - debian/rules: set upstreamversion to 4.5.2
  - Don't install /usr/bin/preparetips
  - Add Replaces/Breaks for libkutils4 in:
    - libkcmutils4
    - libkemoticons4
    - libkidletime4
    - libkprintutils4

  [ Jonathan Kolberg ]
  * New upstream release
  * Now included in upstream
   - kubuntu_72_previewjob_skip_remote_directories.diff
   - kubuntu_75__fix_containment_configs.diff
   - kubuntu_73_fix_mem_leak_kmodelindexproxymapper.diff
   - kubuntu_74_fix_mem_leak_kwebpluginfactory.diff
   - kubuntu_76_fix_install_plasmoid.diff

  [ Rohan Garg ]
  * Add kubuntu_78_krun_http.diff to fix https handling

kde4libs (4:4.5.1-1) UNRELEASED; urgency=low

  * New upstream release.

  [ Modestas Vainius ]
  * Point debian/control Vcs fields to the new Git repository.
  * Bump Standards-Version to 3.9.1: add Breaks next to Replaces where needed.
  * kdelibs5-data should break/replace kdelibs-data 4:3.5.10.dfsg.1-4 as well.
    That version still has the same files as kdelibs5-data.

  [ George Kiagiadakis ]
  * Change my email address in uploaders.
  * Adjust build dependencies:
    - Bump required cmake version to 2.6.4.
    - Bump required soprano version to 2.4.63.
    - Add build dependencies on:
      - libdbusmenu-qt-dev
      - docbook-xml
      - docbook-xsl
      - libxrender-dev
      - libkrb5-dev
    - Remove unused build dependencies:
      - libcups2-dev
      - libdbus-1-dev
      - libasound2-dev
      - libkeyutils-dev
      - xsltproc
      - libxcursor-dev
      - libxtst-dev
  * Update installed files.
  * Add packages for the new libararies: libkatepartinterfaces4,
    libkcmutils4, libkidletime4, libkemoticons4, libkprintutils4.
  * Update symbol files.
  * Add symbol files for the new libraries.
  * Remove libkutils4.symbols as kutils is now a dummy
    transitional library with no symbols.
  * Refresh patches.
  * Add docbook-xml dependency on the kdoctools package,
    as it is required for building all of kde's documentation.

kde4libs (4:4.5.1-0ubuntu8) maverick-proposed; urgency=low

  * Add kubuntu_78_kate_buffer.diff from 4.5.2, fixes KDevelop's use of
    Kate. LP: #656195
 -- Rohan Garg <rohangarg at kubuntu.org>   Sat, 16 Oct 2010 00:58:44 +0530

** Changed in: kde4libs (Ubuntu Natty)
       Status: Fix Committed => Fix Released

-- 
kdevelop crashes
https://bugs.launchpad.net/bugs/656195
You received this bug notification because you are a member of Kubuntu
Bugs, which is subscribed to kde4libs in ubuntu.




More information about the kubuntu-bugs mailing list