[Bug 585930] [NEW] kdm starts before nvidia driver is fully loaded

Antonio Barbuzzi antoniob82 at gmail.com
Wed May 26 15:53:57 UTC 2010

Public bug reported:

Binary package hint: kdm

After the boot, kdm tries to start before nvidia driver is fully loaded.
Looking in kern.log, nvidia module start to load, but it takes about 2 seconds to finish.
Meantime, kdm start and complains about a missing Nvidia kernel module.
After restarting X, everything works well, with the nvidia module properly working.

Hereafter kdm and kern log extracted and time sorted:

kern.log: NVIDIA: could not open the device file /dev/nvidiactl (No such device or address).
kern.log: 09:27:26 nvidia_bl: MacBookPro 5,4 detected
kern.log: 09:27:26 nvidia_bl: Nvidia graphics adapter 10de:0863 (106b:00ba) detected
kern.log: 09:27:26 nvidia: module license 'NVIDIA' taints kernel.

kdm.log: (EE) 09:27:27 NVIDIA(0): Failed to initialize the NVIDIA kernel module. Please see the
kdm.log: (EE) 09:27:27 NVIDIA(0):     system's kernel log for additional error messages and
kdm.log: (EE) 09:27:27 NVIDIA(0):     consult the NVIDIA README for details.
kdm.log: (EE) NVIDIA(0):  *** Aborting ***

kern.log: 09:27:28 nvidia 0000:00:03.5: PCI INT B -> Link[LPMU] -> GSI 21 (level, low) -> IRQ 21
kern.log: 09:27:28 nvidia: probe of 0000:00:03.5 failed with error -1
kern.log: 09:27:28 nvidia 0000:03:00.0: PCI INT A -> Link[LGPU] -> GSI 20 (level, low) -> IRQ 20
kern.log: 09:27:28 nvidia 0000:03:00.0: setting latency timer to 64

My nvidia module version is the lastest, 195.36.15. I suspect that the problems is related with upstart,
since it doesn't verify that the needed driver is fully loaded.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: kdm 4:4.4.2-0ubuntu14
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic
Uname: Linux 2.6.32-22-generic x86_64
NonfreeKernelModules: wl nvidia
Architecture: amd64
Date: Wed May 26 17:29:45 2010
EcryptfsInUse: Yes
 PATH=(custom, user)
SourcePackage: kdebase-workspace

** Affects: kdebase-workspace (Ubuntu)
     Importance: Undecided
         Status: New

** Tags: amd64 apport-bug lucid

kdm starts before nvidia driver is fully loaded
You received this bug notification because you are a member of Kubuntu
Bugs, which is subscribed to kdebase-workspace in ubuntu.

More information about the kubuntu-bugs mailing list