[Bug 611579] [NEW] Kile does not remember custom Latex commands

plotzer 611579 at bugs.launchpad.net
Fri Jul 30 06:48:16 UTC 2010


Public bug reported:

Binary package hint: kile

Hi there,

I am trying to defining a custom Latex Command (via Settings->Configure Kile->Latex,General->Commands Configure->Commands Add).
If I add a new Reference command with the name prettyref, this command can be used properly in the running session (autocompletion works, autoexpansion of labels works). However, when closing and restarting Kile my custom command is gone.  

Kile seems to fail in storing the command to kilerc. Here is hat happens.
When closing Kile, I get the following error printed in the terminal:

kile(3364)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
"KConfigIni: In file /home/plotzer/.kde/share/config/kilerc, line 169: " "Invalid escape sequence "\p"."

And the corresponding line in the file ends up to be: 
kilerc, line 169: \\rettyref=R,,,{ }

and the upon restart, the custom command is gone (could not be loaded
from kilerc, I guess).


I hope this helps to track down the problem.


Thanks in advance, 
alex

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: kile 1:2.1.0~svn1112263beta4-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-24.38-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-24-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Fri Jul 30 08:29:41 2010
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100427.1)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: kile

** Affects: kile (Ubuntu)
     Importance: Undecided
         Status: New


** Tags: amd64 apport-bug lucid

-- 
Kile does not remember custom Latex commands
https://bugs.launchpad.net/bugs/611579
You received this bug notification because you are a member of Kubuntu
Bugs, which is subscribed to kile in ubuntu.




More information about the kubuntu-bugs mailing list