[Bug 512932] [NEW] Amarok sound output crashes at random

Luke lukem33p at gmail.com
Tue Jan 26 19:58:25 UTC 2010


Public bug reported:

Binary package hint: amarok

In Amarok, under the default-version Gnome desktop, the sound output
through a Riptide ALSA sound card crashes. The device is still
functional, outputting sound through the test function of the default
sound configuration for Amarok, but the Amarok plugin disappears from
the sound preferences console, cutting off output from Amarok. Other
applications, including Rhythmbox, function normally. Amarok application
still runs and appears to be playing meanwhile. After quitting the
application (including the notification app) and restarting (the app),
the plugin reinstates itself, and functions normally until a later crash
(usually 10-20 minutes later). When monitoring during the crash, CPU
power is available, as is RAM.

The CPU is a higher-end Intel Coppermine (first run), and there is 364
MB of memory. The SWAP file is around 2 GB on an IDE hard drive
(possibly 5400 RPM).

This crash has happened since a kernel upgrade, to a version of 2.6
ending in a ".17". The app has not been uninstalled and reinstalled.

The Version of Gnome in question is 2.26, and the Ubuntu in use is
version 9.10 with KDE desktop packages installed, along with a linuxant
coexant driver for Riptide audio solutions, which seems to not be
proprietary. A generic .deb was used, reinstalled after the Kernel
upgrade. The Driver was correctly identified by all components.

ProblemType: Bug
Architecture: i386
Date: Tue Jan 26 11:32:42 2010
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/amarok
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
Package: amarok 2:2.2.0-0ubuntu2
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-17.54-generic-pae
SourcePackage: amarok
Uname: Linux 2.6.31-17-generic-pae i686
XsessionErrors:
 (gnome-settings-daemon:1607): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (nautilus:1663): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (polkit-gnome-authentication-agent-1:1672): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (gnome-panel:1662): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -5 and height 24

** Affects: amarok (Ubuntu)
     Importance: Undecided
         Status: New


** Tags: apport-bug i386

-- 
Amarok sound output crashes at random
https://bugs.launchpad.net/bugs/512932
You received this bug notification because you are a member of Kubuntu
Bugs, which is subscribed to amarok in ubuntu.




More information about the kubuntu-bugs mailing list