[Bug 512799] [NEW] plasma-scriptengine-python API error

AdrianvV adrianvv at soultrap.net
Tue Jan 26 14:20:43 UTC 2010


Public bug reported:

Binary package hint: plasma-scriptengine-python

Description:    Ubuntu 9.10
Release:        9.10

plasma-scriptengine-python:
  Installed: 4:4.3.95-0ubuntu1~karmic1~ppa2
  Candidate: 4:4.3.95-0ubuntu1~karmic1~ppa2
  Version table:
 *** 4:4.3.95-0ubuntu1~karmic1~ppa2 0
        500 http://ppa.launchpad.net karmic/main Packages
        100 /var/lib/dpkg/status
     4:4.3.4-0ubuntu1~karmic1 0
        500 http://za.archive.ubuntu.com karmic-backports/main Packages
     4:4.3.2-0ubuntu7.1 0
        500 http://za.archive.ubuntu.com karmic-updates/main Packages
     4:4.3.2-0ubuntu7 0
        500 http://za.archive.ubuntu.com karmic/main Packages


First noticed this when the gmail-plasmoid didn't want to load. When trying to remove the plasmoid and then re-add it the plasma-desktop kept crashing so I had to start it manually and the subsequent debug info showed the error:

Start Dragging                                                                                                                                                       
plasma-desktop(23739)/libplasma Plasma::Applet::load: we have a script using the "python" API                                                                        
plasma-desktop(23739)/python (plugin) KPythonPluginFactory::KPythonPluginFactory: KPythonPluginFactory::KPythonPluginFactory()                                       
plasma-desktop(23739)/python (plugin) KPythonPluginFactory::initialize: Initializing Python interpreter.                                                             
plasma-desktop(23739)/python (plugin) KPythonPluginFactory::initialize: Succesfully initialized Python interpreter.                                                  
plasma-desktop(23739)/python (plugin) KPythonPluginFactory::create: KPythonPluginFactory::create iface:  Plasma::AppletScript                                        
plasma-desktop(23739)/python (plugin) KPythonPluginFactory::create: keyword to be used for finding the plugin code:  "plasma_scriptengine_python/pyappletscript.py"  
plasma-desktop(23739)/python (plugin) KPythonPluginFactory::create: Path to plugin code is:  "/usr/share/kde4/apps/plasma_scriptengine_python/pyappletscript.py"     
plasma-desktop(23739)/python (plugin): Failed to import module                                                                                                       
Traceback (most recent call last):                                                                                                                                   
  File "/usr/share/kde4/apps/plasma_scriptengine_python/pyappletscript.py", line 22, in <module>                                                                     
    from PyKDE4.plasma import Plasma                                                                                                                                 
RuntimeError: the sip module implements API v7.0 but the PyKDE4.plasma module requires API v6.0                                                                      
plasma-desktop(23739)/libplasma Plasma::loadEngine: Couldn't load script engine for language  "python" ! error reported:  "The service 'Python Widget' does not provide an interface 'Plasma::AppletScript' with keyword 'plasma_scriptengine_python/pyappletscript.py'"                                                                          
plasma-desktop(23739)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0)                                                                                 

Also:

$ apport-bug
Traceback (most recent call last):
  File "/usr/share/apport/apport-kde", line 28, in <module>
    from PyKDE4.kdecore import (ki18n, KAboutData, KCmdLineArgs,
RuntimeError: the sip module implements API v7.0 but the PyKDE4.kdecore module requires API v6.0


Package versions:
ii  plasma-desktop                            4:4.3.95-0ubuntu1~karmic1~ppa2                         The KDE plasma workspace for desktop and lap
ii  plasma-scriptengine-python                4:4.3.95-0ubuntu1~karmic1~ppa2                         Python script engine for Plasma


I don't have any stale 4.3.90 packages lying around.

** Affects: kdebase-workspace (Ubuntu)
     Importance: Undecided
         Status: New

** Affects: python-kde4 (Debian)
     Importance: Unknown
         Status: Unknown

-- 
plasma-scriptengine-python API error 
https://bugs.launchpad.net/bugs/512799
You received this bug notification because you are a member of Kubuntu
Bugs, which is subscribed to kdebase-workspace in ubuntu.




More information about the kubuntu-bugs mailing list