[Bug 486319] [NEW] software-properties-kde crash

danutzdobrescu danutzdobrescu at gmail.com
Sat Nov 21 15:45:11 UTC 2009


Public bug reported:

Binary package hint: python-qt4

danutz at compy:~$ sudo software-properties-kde
Traceback (most recent call last):
  File "/usr/bin/software-properties-kde", line 122, in <module>
    app = SoftwarePropertiesKDE(datadir=data_dir, options=options, file=file, attachWinID=attachWinID)
  File "/usr/lib/python2.6/dist-packages/softwareproperties/kde/SoftwarePropertiesKDE.py", line 104, in __init__
    self.show_keys()
  File "/usr/lib/python2.6/dist-packages/softwareproperties/kde/SoftwarePropertiesKDE.py", line 606, in show_keys
    self.userinterface.treeview2.addTopLevelItem(QTreeWidgetItem([utf8(key)]))
  File "/usr/lib/python2.6/dist-packages/softwareproperties/kde/SoftwarePropertiesKDE.py", line 57, in utf8
    return unicode(str, 'UTF-8')
  File "/usr/lib/python2.6/encodings/utf_8.py", line 16, in decode
    return codecs.utf_8_decode(input, errors, True)
UnicodeDecodeError: 'utf8' codec can't decode bytes in position 45-46: invalid data
Exception TypeError: TypeError("'NoneType' object is not callable",) in <bound method Popen.__del__ of <subprocess.Popen object at 0xa845eec>> ignored

I've tried reinstalling python-qt4, but without any result .. 
I'm running Karmic Koala 32bit, up to date...  i've seen on some external forums the same error but i didn't found any result

** Affects: python-qt4 (Ubuntu)
     Importance: Undecided
         Status: New

-- 
software-properties-kde crash
https://bugs.launchpad.net/bugs/486319
You received this bug notification because you are a member of Kubuntu
Bugs, which is subscribed to python-qt4 in ubuntu.




More information about the kubuntu-bugs mailing list