[Bug 278062] Re: Rosegarden depends on Dolphin file manager

Cesare Tirabassi cesare.tirabassi at gmail.com
Mon Oct 13 19:56:41 UTC 2008


Is this a packaging problem, or a problem coming from upstream?
For hardy, kdebase-bin depends on:

kdebase-bin-kde3, kdelibs4c2a (>= 4:3.5.8-1), libacl1 (>= 2.2.11-1),
libart-2.0-2 (>= 2.3.18), libattr1 (>= 2.4.4-1), libaudio2, libc6 (>=
2.4), libfontconfig1 (>= 2.4.0), libfreetype6 (>= 2.3.5), libgcc1,
libice6 (>= 1:1.0.0), libidn11 (>= 0.5.18), libjpeg62, libpam-runtime
(>= 0.76-14), libpam0g (>= 0.99.7.1), libpng12-0 (>= 1.2.13-4),
libqt3-mt (>= 3:3.3.8-b), libsm6, libstdc++6 (>= 4.2.1-4), libx11-6,
libxcursor1 (>> 1.1.2), libxext6, libxft2 (>> 2.1.1), libxi6,
libxinerama1, libxkbfile1, libxrandr2 (>= 2:1.2.0), libxrender1, libxt6,
libxtst6, zlib1g (>= 1:1.2.3.3.dfsg-1)

Which looks pretty sensible.
For intrepid:

dolphin, kdebase-runtime (>= 4:4.1.2), kdelibs5 (>= 4:4.1.2), libc6 (>=
2.4), libgl1-mesa-glx | libgl1, libglu1-mesa | libglu1, libqt4-dbus (>=
4.4.3), libqt4-qt3support (>= 4.4.3), libqtcore4 (>= 4.4.3), libqtgui4
(>= 4.4.3), libraw1394-8, libstdc++6 (>= 4.2.1), libx11-6, kdebase-data
(= 4:4.1.2-0ubuntu3)

So, just because of this single dependency you get kdelibs5, kdebase-
runtime, dolphin and all associated dependancies.

If its a packaging problem, this could be solved by splitting the
package. Perhaps a kdebase-bin-kde3/kdebase-bin-kde4 split (with all
legacy applications using  kdebase-bin-kde3), or making separate kdebase
packages; I don't know why dolphin, kdebase-runtime and kdelibs5 are now
required to be deps, but for instance whoever requires them could be
made to depend on a kdebase-dolphin and/or have explicit deps on
kdelibs5 and kdebase-runtime instead.

-- 
Rosegarden depends on Dolphin file manager
https://bugs.launchpad.net/bugs/278062
You received this bug notification because you are a member of Kubuntu
Bugs, which is subscribed to kdebase in ubuntu.




More information about the kubuntu-bugs mailing list