[Bug 230615] [NEW] Networking destroys ip adresses leaving computers out of networks

Hein van Rensburg hvralpha at intekom.co.za
Thu May 15 06:49:04 UTC 2008

Public bug reported:

Binary package hint: kdenetwork

After a weeks frustrations and testing I have become convinced networking is fundementally broken in 8.04. I also believe it has multiple bugs in different places but am not knowledgeable enough to detect where.
The system currently barely works for a single computer which can connect to internet with network manager. It connects wity pppoeeconf, but shows no IP adresses in network manager nor in systems settings-network. 

I have a office with switch/ADSL router which connects 4 computers. The
router is also the network DHCP server. Any computer can connect
individually to the internet, but has no IP or Lan identification which
gets destroyed in the process.

I removed network manager from all the computers and cleaned up the
etc/network/interfaces file. Network manager did not see any interfaces
although the computers were connected.  After cleaning all the intefaces
out of the interfaces file, the interfaces did show up in network
manager, but the dsl was disconnected.( Bug 1 in network manager).  It
worked after I ran sudo pppoeconf on each computer again. However, this
put the interfaces into a manual mode and destroyed any networking.

After I removed Knetwork manager, reset and there was no connection. ( I
have knemo installed so I can watch the interfaces). I went to system
settings and configured the interfaces dhcp. This is where I found bug
nr 2. (You have to reconfigure twice before it actually takes and shows
a IP address). Most people would be discouraged right here as systems
settings does not work properly). I had to reload the gateway and domain
name in system settings in each case. Reloading disconnected the
computers again and the only way I could get them back on the net was to
run sudo pppoeconf again.

This worked, but after switching off and back on, the computer connected
but the IP, Gateway and and domain name was destroyed again. ( Bug nr

Soe 8.04 leaves us in a position where you can be connceted to the internet through ASDL ( pppoeconf) juggling, but the network can never work.
Needs urgent  attention in different places. Pls help

** Affects: kdenetwork (Ubuntu)
     Importance: Undecided
         Status: New

** Tags: ip network networkmanager systemsettings

Networking destroys ip adresses leaving computers out of networks
You received this bug notification because you are a member of Kubuntu
Team, which is subscribed to kdenetwork in ubuntu.

More information about the kubuntu-bugs mailing list