[Bug 311258] [NEW] Few Zeroconf Service Types Work in Dolphin

Launchpad Bug Tracker 311258 at bugs.launchpad.net
Sun Dec 28 16:24:46 UTC 2008


You have been subscribed to a public bug:

When I add a service file to my /etc/avahi/services/ folder dolphin does not display them with the zeroconf:/ kio.
I automatically thought that I had done something wrong even though the service files worked in the last release fine so I tested them against the avahi-browse application and they worked fine there so this must be a fault in Dolphin and not the Avahi Zeroconf implementation. This gets a little bit more distorted when I add the ssh service file (a duplicate of the example file from the docs folder) and it displays as a fish service and connects as a fish service but shows up fine in the avahi-browse app mentioned earlier.

Example ssh.service file (That shows as a fish service in Dolphin):
<service-group>

   <name replace-wildcards="yes">Remote Terminal on %h</name>

   <service>
     <type>_ssh._tcp</type>
     <port>22</port>
   </service>

Example smb.service file (That does bugger all in Dolphin):
<service-group>

  <name replace-wildcards="yes">%h</name>

  <service>
    <type>_smb._tcp</type>
    <port>445</port>
  </service>

Please can this be investigated please as it appears to have been borked
between 8.04 and 8.10

1) The release of Ubuntu you are using: 8.10
2) The version of the package you are using: 4:4.1.3-0ubuntu1~intrepid1
3) What you expected to happen: All possible service types to work.
4) What happened instead: Bugger All.

** Affects: kde4libs (Ubuntu)
     Importance: Undecided
         Status: New

-- 
Few Zeroconf Service Types Work in Dolphin
https://bugs.edge.launchpad.net/bugs/311258
You received this bug notification because you are a member of Kubuntu Bugs, which is subscribed to kde4libs in ubuntu.




More information about the kubuntu-bugs mailing list