[Bug 114500] can't upgrade/remove k3b

Denis Jacquerye moyogo at gmail.com
Sun May 13 20:28:07 UTC 2007


Public bug reported:

Binary package hint: k3b

Can't upgrade k3b nor remove it.

The result after trying to upgrade is the following:

fejack at bigfoot:~$ sudo dpkg -r k3d
dpkg: error processing k3d (--remove):
 Package is in a very bad inconsistent state - you should
 reinstall it before attempting a removal.
Errors were encountered while processing:
 k3d
fejack at bigfoot:~$ apt-get -f install
E: Could not open lock file /var/lib/dpkg/lock - open (13 Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
fejack at bigfoot:~$ sudo apt-get -f install
Password:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  kdelibs4-dev kdemultimedia-dev libswscalecvs0 libavahi-qt3-dev
  libavutilcvs49 libarts1-dev
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  k3d
Suggested packages:
  aqsis
The following packages will be upgraded:
  k3d
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 10.9MB of archives.
After unpacking 840kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://it.archive.ubuntu.com feisty/universe k3d 0.6.6.0.ds1-1 [10.9MB]
Fetched 10.9MB in 18s (576kB/s)                                                
Selecting previously deselected package k3d.
(Reading database ... 178784 files and directories currently installed.)
Preparing to replace k3d 0.5.12.0-1ubuntu2 (using .../k3d_0.6.6.0.ds1-1_i386.deb) ...
Traceback (most recent call last):
  File "/usr/bin/pycentral", line 1394, in <module>
    main()
  File "/usr/bin/pycentral", line 1388, in main
    rv = action.run(global_options)
  File "/usr/bin/pycentral", line 955, in run
    pkg.read_version_info()
  File "/usr/bin/pycentral", line 542, in read_version_info
    raise PyCentralError, "package has no field Python-Version"
__main__.PyCentralError: package has no field Python-Version
dpkg: warning - old pre-removal script returned error exit status 1
dpkg - trying script from the new package instead ...
Usage: update-python-modules [-v] [-c] package_directory [...]
       update-python-modules [-v] [-c] package.dirs [...]
       update-python-modules [-v] [-a|-f]

update-python-modules: error: /usr/share/python-support/k3d.dirs does not exist
dpkg: error processing /var/cache/apt/archives/k3d_0.6.6.0.ds1-1_i386.deb (--unpack):
 subprocess new pre-removal script returned error exit status 2
Traceback (most recent call last):
  File "/usr/bin/pycentral", line 1394, in <module>
    main()
  File "/usr/bin/pycentral", line 1388, in main
    rv = action.run(global_options)
  File "/usr/bin/pycentral", line 879, in run
    pkg.read_version_info()
  File "/usr/bin/pycentral", line 542, in read_version_info
    raise PyCentralError, "package has no field Python-Version"
__main__.PyCentralError: package has no field Python-Version
dpkg: error while cleaning up:
 subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
 /var/cache/apt/archives/k3d_0.6.6.0.ds1-1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

** Affects: k3b (Ubuntu)
     Importance: Undecided
         Status: Unconfirmed

-- 
can't upgrade/remove k3b
https://bugs.launchpad.net/bugs/114500
You received this bug notification because you are a member of Kubuntu
Team, which is a bug contact for k3b in ubuntu.




More information about the kubuntu-bugs mailing list