[Bug 108185] Re: Adept fails to install ubuntu-restricted-extras although apt-get installs it just fine.

Richard Birnie arbyuk at googlemail.com
Sun May 6 14:17:57 UTC 2007


Laur,

I agree that this should be handled more gracefully so I spent sometime
trying to reproduce the problem. What follows is my description of what
occurred. Can you confirm if this matches what you observed. It gets a
bit long but I'm trying to be as complete as possible to try and get
this fixed.

I attempted to install ubuntu-restricted-extras using adept manager. When adept gets to installing sun-java6-bin the license agreement appears in a dialogue box titled 'debconf on mycomputer'. If I click next without checking the 'I accept' box then the embedded dpkg output in attempt reports an error: 
dpkg: error processing /var/cache/apt/archives/sun-java6-bin_6-00-2ubuntu-2_i386.deb (--unpack)
subprocess pre-installation script returned an error exit status 1.

I also get a dialogue box with the message:

Declined Operating System Distributor License for Java v1.1 (DLJ)
If you do not agree to the DLJ license terms you cannot install this software
The installation of this package will be cancelled.

I click next and I get another message box titled 'Could not commit
changes - Adept Manager' with the text:

There was an error committing changes. Possible reasons include problems
downloading some of the packages or that the commit would break other
packages.

At the same time I see a second copy of the java license agreement
appear because Adept appears to be trying to install sun-java6-jre. If I
click OK in the 'Could not commit changes' box then Adept crashes and
generates a backtrace. See attached. I will also attach dpkg.log for the
session.

I had to run sudo dpkg --configure -a to get adept back in a usable
condition. Then I repeated my attempt to install ubuntu-restricted-
extras. If I accept the java license then the installation completes
without errors.

Laur, is this consistent with what you observed? If your crash generated
a backtrace could you attach it if you still have it.

** Attachment added: "adept_crash_backtrace"
   http://librarian.launchpad.net/7570854/adept_crash_backtrace

-- 
Adept fails to install ubuntu-restricted-extras although apt-get installs it just fine.
https://bugs.launchpad.net/bugs/108185
You received this bug notification because you are a member of Kubuntu
Team, which is a bug contact for adept in ubuntu.




More information about the kubuntu-bugs mailing list