[Bug 81577] Amarok crashes in xubuntu

Jonathan Temple jontemple at gmail.com
Fri Jan 26 03:12:23 UTC 2007

Public bug reported:

Binary package hint: amarok

I have a fairly new xubuntu install, and I recently tried to install
amarok from the kubuntu amarok repository.

I added the amarok repositories to my apt sources.list and ran "sudo
aptitude install amarok". It went about installing all dependencies.
When it finished, I tried to run amarok, but it crashed with the
following error:

Floating point exception (core dumped)

further investigation shows a crash when trying to start kdeinit:

jon at gimli:~$ kdeinit
Creating link /home/jon/.kde/socket-gimli.
Created link from "/home/jon/.kde/socket-gimli" to "/tmp/ksocket-jon"
kdeinit: Shutting down running client.
It looks like dcopserver is already running. If you are sure
that it is not already running, remove /home/jon/.DCOPserver_gimli__0
and start dcopserver again.

Creating link /home/jon/.kde/tmp-gimli.
Created link from "/home/jon/.kde/tmp-gimli" to "/tmp/kde-jon"
kded: ERROR: Communication problem with kded, it probably crashed.
jon at gimli:~$ 

I actually tried installing kubuntu-desktop and logging into KDE. When
logged into kde, amarok actually ran. Logging back into XFCE, it
crashed. What's going on?

** Affects: amarok (Ubuntu)
     Importance: Undecided
         Status: Unconfirmed

Amarok crashes in xubuntu

More information about the kubuntu-bugs mailing list