[Bug 179524] NTFS volume mounted with wrong options

Marcus marcus.kall at gmail.com
Mon Dec 31 10:50:34 UTC 2007


Public bug reported:

Binary package hint: kdebase-kio-plugins

When I mount my external usb harddrive, which has one ntfs partion, in
kde I can't see filenames with non-standard characters (in my case
swedish åäö). No matter if the utf8 options is turned on or off. I have
tried both by clicking on the harddrive on the desktop and use
kio_media_mounthelper directly.

If I use "gnome-mount", "sudo mount" or "pmount" everythings works ok.

I started hald with --daemon=no --verbose=yes options and tried to track the difference between gnome-mount and kio_media_mounthelper. I found that gnome-mount sends the following options:
given_options[0] = 'locale=sv_SE.UTF-8'
given_options[1] = 'exec'

but kio_media_mounthelper sends 
given_options[0] = 'utf8'

That difference may have something to do with this bug.

** Affects: kdebase (Ubuntu)
     Importance: Undecided
         Status: New

-- 
NTFS volume mounted with wrong options
https://bugs.launchpad.net/bugs/179524
You received this bug notification because you are a member of Kubuntu
Team, which is a bug contact for kdebase in ubuntu.




More information about the kubuntu-bugs mailing list