[Bug 35824] Keyboard Layout options: The "X86AudioRaiseVolume" button stopped working in Logitech keyboard models

Teemu Likonen tlikonen at iki.fi
Tue Mar 21 09:01:22 UTC 2006

Public bug report changed:

I think I know now what is the problem. New "/etc/X11/xkb/symbols/inet"
file contains the following section:

xkb_symbols "logitech_base" {
    key <I01> { [ XF86AudioMedia ] };
    key <I2F> { [ XF86AudioRaiseVolume ] };
    key <I30> { [ XF86AudioRaiseVolume ] };
    key <I6D> { [ XF86AudioMedia ] };

I'm using "logicdp" (Logitech Cordless Desktop Pro) keyboard model and
these two buttons, XF86AudioMedia and XF86AudioRaiseVolume, cause
previously mentioned problems with KDE. As we can see, there are two
definitions for these keys. If I comment out the ones that do not apply
to my keyboard, these keys work correctly with KDE.

The older "inet" file worked fine because there was a unique section for
every Logitech keyboard model. This new "inet" has generic logitech_base
section that is included to every logiXXXX keyboard model.

Well, this is all I can do. Hope this is solved soon somehow - whether
it's xkeyboard-config's or KDE's problem.

More information about the kubuntu-bugs mailing list