[Bug 28155] k3b complains about missing cdrecord and cdrdao unless I run it as root

syntheticzero mitsu at syntheticzero.com
Thu Mar 16 19:56:50 UTC 2006

Public bug report changed:

I encountered this bug after doing an apt-get dist-upgrade as root after
installing Ubuntu 5.10 and then adding KDE by manually installing a
bunch of packages (essentially making my distribution Kubuntu).  k3b
worked fine out of the box but after the dist-upgrade (done yesterday,
2006/03/15), it stopped working with the above error message.  It
suggested I needed to install some packages so I did so, but I still got
"program not found" error unless I ran k3b as root.  Checking the
permissions of the cdrecord and other executables it was complaining
about, I saw they were set to be owned by root and not accessible to
anyone else.  I then ran k3bsetup2 and tried changing the "burning
group" (initially set to "burning" which doesn't exist on Ubuntu ---
thus I guess it was defaulting to root) to the group of my main login
user --- and all was well.

Either the dist-upgrade changed the "burning group" to a nonexistent
group, and thus made cdrecord, etc., only accessible to root, or perhaps
the fact that I ran dist-upgrade as root did this, or something.  In any
event a solution to this might be to make "burning" an actual group that
the main user is made part of.

More information about the kubuntu-bugs mailing list