[Bug 35058] kmail segfault when fetching Disconnected IMAP Mails

pdreker patrick at dreker.de
Wed Mar 15 14:43:53 UTC 2006


Public bug reported:
https://launchpad.net/malone/bugs/35058

Affects: kdepim kmail (Ubuntu)
       Severity: Normal
       Priority: (none set)
         Status: Unconfirmed

Description:
since today dist-upgrade kmail (and kmail in kontact too) segfaults when
trying to fetch mail from an disconnected IMAP account.

Backtrace:
(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1248688448 (LWP 14688)]
[New Thread -1278100560 (LWP 14695)]
[New Thread -1269707856 (LWP 14694)]
[New Thread -1261315152 (LWP 14693)]
[New Thread -1252922448 (LWP 14692)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0xb7cb90ef in KMFolderImap::flagsToStatus ()
   from /usr/lib/libkmailprivate.so
#7  0xb7cd4085 in KMFolderCachedImap::slotGetMessagesData ()
   from /usr/lib/libkmailprivate.so
#8  0xb7cd59c7 in KMFolderCachedImap::qt_invoke ()
   from /usr/lib/libkmailprivate.so
#9  0xb709d2d5 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#10 0xb5b63a56 in KIO::TransferJob::data () from /usr/lib/libkio.so.4
#11 0xb5b63ac0 in KIO::TransferJob::slotData () from /usr/lib/libkio.so.4
#12 0xb5bb52de in KIO::TransferJob::qt_invoke () from /usr/lib/libkio.so.4
#13 0xb709d2d5 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#14 0xb5b61242 in KIO::SlaveInterface::data () from /usr/lib/libkio.so.4
#15 0xb5bcd1e5 in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.4
#16 0xb5b742e9 in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.4
#17 0xb5b78af0 in KIO::Slave::gotInput () from /usr/lib/libkio.so.4
#18 0xb5b78c85 in KIO::Slave::qt_invoke () from /usr/lib/libkio.so.4
#19 0xb709d2d5 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#20 0xb709dbe4 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#21 0xb742d153 in QSocketNotifier::activated () from /usr/lib/libqt-mt.so.3
#22 0xb70bd602 in QSocketNotifier::event () from /usr/lib/libqt-mt.so.3
#23 0xb70336c2 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#24 0xb70338b4 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#25 0xb772bc7d in KApplication::notify () from /usr/lib/libkdecore.so.4
#26 0xb6fc4993 in QApplication::sendEvent () from /usr/lib/libqt-mt.so.3
#27 0xb70251df in QEventLoop::activateSocketNotifiers ()
   from /usr/lib/libqt-mt.so.3
#28 0xb6fd875b in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#29 0xb704c1bb in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#30 0xb704c0de in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#31 0xb70321d1 in QApplication::exec () from /usr/lib/libqt-mt.so.3
#32 0x0804a04b in ?? ()
#33 0xbfbffe78 in ?? ()
#34 0xbfc00064 in ?? ()
#35 0x00000000 in ?? ()

This renders kmail/kontact almost completely unusable. The behaviour is
100% reproducible. Rebuilding the IMAP Cache Index does not fix it,
neither does completely rebuilding the IMAP Cache fix the problem.

KMail/Kontact version: 3.5.1-0ubuntu4, Distribution: Dapper, completely
up-to-date




More information about the kubuntu-bugs mailing list