[Bug 51109] K menu>System Settings>Display

Gary garymax at earthlink.net
Tue Jun 27 13:37:14 UTC 2006


Public bug reported:

When setting monitor power management using <system settings> in the K
menu in Administrator mode, screen flickers after logging in as 'sudo'
and a new xorg.conf file is generated which has the output below. Upon a
computer restart X server fails with Ring Buffer error. Note that the
original is renamed as xorg.conf.1.

Output of rewritten xorg.conf file:

Section "Device"
  identifier "Intel Corporation 82810 CGC [Chipset Graphics Controller]"
  boardname "i810"
  busid "PCI:0:1:0"
  driver "i810"
  screen 0
EndSection

Section "Monitor"
  identifier "Acer AL1912"
  vendorname "Plug 'n' Play"
  modelname "Plug 'n' Play"
  modeline  "640x480 at 60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
  modeline  "640x480 at 72" 31.5 640 664 704 832 480 489 491 520 -vsync -hsync
  modeline  "640x480 at 75" 31.5 640 656 720 840 480 481 484 500 -vsync -hsync
  modeline  "800x600 at 56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
  modeline  "800x600 at 72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
  modeline  "800x600 at 75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
  modeline  "800x600 at 60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
  modeline  "832x624 at 75" 57.284 832 864 928 1152 624 625 628 667 -vsync -hsync
  modeline  "1024x768 at 75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
  modeline  "1024x768 at 70" 75.0 1024 1048 1184 1328 768 771 777 806 -vsync -hsync
  modeline  "1024x768 at 60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
  modeline  "1152x864 at 75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
  modeline  "1152x768 at 54" 64.995 1152 1178 1314 1472 768 771 777 806 +hsync +vsync
  modeline  "1280x854" 80.0 1280 1309 1460 1636 854 857 864 896 +hsync +vsync
  modeline  "1280x1024 at 75" 135.0 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
  modeline  "1280x960 at 60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
  modeline  "1280x1024 at 60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
  modeline  "1280x960 at 75" 129.86 1280 1368 1504 1728 960 961 964 1002 -hsync +vsync
  modeline  "1400x1050 at 60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
  modeline  "1600x1200 at 60" 162.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
  gamma 1.0
EndSection

Section "Screen"
  Identifier "Default Screen"
  Device "Intel Corporation 82810 CGC [Chipset Graphics Controller]"
  Monitor "Acer AL1912"
  DefaultDepth 24
  SubSection "Display"
    depth 24
    virtual 1600 1200
    modes "1280x1024 at 75" "1280x960 at 60" "1280x854" "1280x1024 at 60" "1152x768 at 54" "1280x960 at 75" "1152x864 at 75" "1400x1050 at 60" "1024x768 at 60" "1600x1200 at 60" "1024x768 at 70" "1024x768 at 75" "832x624 at 75" "800x600 at 60" "800x600 at 75" "800x600 at 72" "800x600 at 56" "640x480 at 75" "640x480 at 72" "640x480 at 60"
  EndSubSection
EndSection

This is different from the good (and working) xorg.conf file as shown
below:


Section "Device"
   Identifier   "Intel Corporation 82810 CGC [Chipset Graphics Controller]"
   Driver      "i810"
   BusID      "PCI:0:1:0"
EndSection

Section "Monitor"
   Identifier   "Acer AL1912"
   Option      "DPMS"
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "Intel Corporation 82810 CGC [Chipset Graphics Controller]"
   Monitor      "Acer AL1912"
   DefaultDepth   16
   SubSection "Display"
      Depth      1
      Modes      "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      4
      Modes      "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      8
      Modes      "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      15
      Modes      "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      16
      Modes      "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      24
      Modes      "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
   EndSubSection
EndSection

** Affects: kde-systemsettings (Ubuntu)
     Importance: Untriaged
         Status: Unconfirmed

-- 
K menu>System Settings>Display
https://launchpad.net/bugs/51109




More information about the kubuntu-bugs mailing list