[Bug 31782] FTBFS: kdesdk build-depends on libdb4.2-dev, while it's build-deps depends on libdb4.3-dev

Simon Huerlimann huerlisi at gmail.com
Fri Feb 17 15:49:07 UTC 2006


Public bug reported:
https://launchpad.net/malone/bugs/31782

Affects: kdesdk (Ubuntu)
       Severity: Normal
       Priority: (none set)
         Status: Unconfirmed

Description:
I tried to run 'apt-get build-dep kdesdk' on a freshly installed Dapper system. I run into the following error:
> $ apt-get build-dep kdesdk
> Reading package lists... Done
> Building dependency tree... Done
> The following packages have unmet dependencies.
> E: Build-dependencies for kdesdk could not be satisfied.

After some investigation, I realized, that 'kdesdk' directly build-
depends on 'libdb4.2-dev', while other build-dependencies like
'libapr0-dev' depend on 'libdb4.3-dev' or 'libdb4.4-dev'.

You probably wanna pump the dependency to 'libdb4.3-dev', allow all
three as alternatives or drop it alltogether.

Thanx




More information about the kubuntu-bugs mailing list