[Bug 55502] Amarok randomly cannot initialise xine engine

RobertWiblin robertwiblin at gmail.com
Mon Aug 7 13:39:23 UTC 2006


Public bug reported:

Binary package hint: amarok

I am using amarok on an Ubuntu 6.06 clean install in a Dell Inspiron
6000.

About a quarter of the times I boot the computer, when Amarok loads, it
will give the message

 "xine was unable to initialize any audio-drivers"

and be unable to play any music files (it will be using no audio engine,
or the 'void' engine) until the computer is rebooted. This is despite
audio working fine in other programs, including playing MP3s. When you
attempt to change the engine to xine the error message is just repeated.
This is an apparently random occurence.

I have found the problem to be solved by following the suggestion in the
final post in this this forum thread:

http://www.linuxforums.org/forum/suse-linux-help/58905-amarok-xine-
engine-2.html

"Hi dutchman and islamguide, I had the same problem as you had and I found the solution, thanks to you! I never tried to run amarok as root before seeing your posts.
Well the issue was that in the file ~/.kde/share/config/amarokrc there was a problematic section. Once I removed it I could use amarok w/ xine again.
Unfortunately as I removed it I cannot tell you exactly what it said, I just remember that the section was about xine engine and contained a line that referred to arts. I removed the whole section and no more problem loading audio-drivers
Hope this helps
g"

I will attach a copy of my amarokrc file in the hope that somebody can work out what is problematic about it and perhaps suggest a solution to this bug either to the Ubuntu crew or to the Amarok people.
Thanks.

** Affects: amarok (Ubuntu)
     Importance: Untriaged
         Status: Unconfirmed

-- 
Amarok randomly cannot initialise xine engine
https://launchpad.net/bugs/55502




More information about the kubuntu-bugs mailing list