[Bug 12952] New: no /dev/dsp present and not automatically recognized es1869 snd card

bugzilla-daemon at bugzilla.ubuntu.com bugzilla-daemon at bugzilla.ubuntu.com
Mon Jul 25 18:49:48 UTC 2005

Please do not reply to this email.  You can add comments at
Ubuntu | alsa-driver

           Summary: no /dev/dsp present and not automatically recognized
                    es1869 snd card
           Product: Ubuntu
           Version: unspecified
          Platform: i386
        OS/Version: Linux
            Status: UNCONFIRMED
          Severity: normal
          Priority: P2
         Component: alsa-driver
        AssignedTo: debzilla at ubuntu.com
        ReportedBy: miguipda at hotmail.com
         QAContact: kubuntu-bugs at lists.ubuntu.com
                CC: miguipda at hotmail.com

I am working on a Compaq Deskpro EN Series SFF (600 Mhz, 256 Mb, 40 Gb, ATI Rage pro 
and ES1869 (SB16) motherboard integrated HW). 
My sound was not automatically recognized under ubuntu. I tried "insmod snd-es18xx" 
and then it works well. 
As I prefer to work with KDE I decide to optimize my installation and then download 
the kubuntu cd and install it. Doing this let me reduce the size on my HD by 
preventing gnome occupation and undesired (sorry for who like it). 
Actually, since I installed Kubuntu I can't use the sound. 
Since three days I tried all I found on the different forums. Nothing changed. 
The main problem I I receive a popup windows telling me : 
"Sound server informational message: 
Error while initializing the sound driver: 
device /dev/dsp can't be opened (No such file or directory) 
The sound server will continue, using the null output device." 
Then I searched to first create the /dev/dsp and tried to use the MAKEDEV (see man 
MAKEDEV) as explained in the (/dev) MAKEDEV man page. Nothing changed. 
Then if I hope to be able to use my integrated sound card which previously worked I 
first need to be able to have a /dev/dsp I presume. 
So, let me please tell me how or what must I do under the Kubuntu to be able to ear 
sound. I sincerely need it because I each days phone (VoIP) with Skype in many places 
in the world. Sincerely thanks for your help. 
Please find here below my dmesg, lspci, lsmod (please take notes I do the three 
modprobe fo snd-pcm-oss, snd-mixer-oss,snd-seq-oss before trying the modprobe with 
snd-es18xx (or  even snd-sb16). I tell SB16 because I was surprised to see that the 
AIDA (now renamed EVEREST) that both ES1869 and SB16 was simultaneously present on my 
My dsmeg : 
# dmesg 
Linux version 2.6.10-5-386 (buildd at terranova) (gcc version 3.3.5 (Debian 
1:3.3.5-8ubuntu2)) #1 Tue Apr 5 12:12:40 UTC 2005 
BIOS-provided physical RAM map: 
 BIOS-e820: 0000000000000000 - 000000000009fc00 (usable) 
 BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved) 
 BIOS-e820: 00000000000e0000 - 0000000000100000 (reserved) 
 BIOS-e820: 0000000000100000 - 0000000010000000 (usable) 
 BIOS-e820: 00000000fffc0000 - 0000000100000000 (reserved) 
256MB LOWMEM available. 
On node 0 totalpages: 65536 
  DMA zone: 4096 pages, LIFO batch:1 
  Normal zone: 61440 pages, LIFO batch:15 
  HighMem zone: 0 pages, LIFO batch:1 
DMI 2.1 present. 
ACPI: RSDP (v000 COMPAQ                                ) @ 0x000e0010 
ACPI: RSDT (v001 COMPAQ CPQB053  0x19990821  0x00000000) @ 0x000e0080 
ACPI: FADT (v001 COMPAQ SCARAB   0x00000001  0x00000000) @ 0x000e00cc 
ACPI: SSDT (v001 COMPAQ VILLTBL1 0x00000001 MSFT 0x0100000b) @ 0x000e09c3 
ACPI: SSDT (v001 COMPAQ PNP_PRSS 0x00000001 MSFT 0x0100000b) @ 0x000e19c0 
ACPI: SSDT (v001 COMPAQ      PME 0x00000001 MSFT 0x0100000b) @ 0x000e2134 
ACPI: DSDT (v001 COMPAQ     DSDT 0x00000001 MSFT 0x0100000b) @ 0x00000000 
ACPI: PM-Timer IO Port: 0xf808 
Built 1 zonelists 
Kernel command line: root=/dev/hda2 ro quiet splash 
Local APIC disabled by BIOS -- you can enable it with "lapic" 
mapped APIC to ffffd000 (01204000) 
Initializing CPU#0 
PID hash table entries: 2048 (order: 11, 32768 bytes) 
Detected 597.587 MHz processor. 
Using pmtmr for high-res timesource 
Console: colour VGA+ 80x25 
Dentry cache hash table entries: 65536 (order: 6, 262144 bytes) 
Inode-cache hash table entries: 32768 (order: 5, 131072 bytes) 
Memory: 252188k/262144k available (1436k kernel code, 9372k reserved, 754k data, 224k 
init, 0k highmem) 
Checking if this processor honours the WP bit even in supervisor mode... Ok. 
Calibrating delay loop... 1183.74 BogoMIPS (lpj=591872) 
Security Framework v1.0.0 initialized 
SELinux:  Disabled at boot. 
Mount-cache hash table entries: 512 (order: 0, 4096 bytes) 
CPU: After generic identify, caps: 0383f9ff 00000000 00000000 00000000 00000000 
CPU: After vendor identify, caps: 0383f9ff 00000000 00000000 00000000 00000000 
CPU: L1 I cache: 16K, L1 D cache: 16K 
CPU: L2 cache: 256K 
CPU: After all inits, caps: 0383f9ff 00000000 00000000 00000040 00000000 00000000 
CPU: Intel Pentium III (Coppermine) stepping 03 
Enabling fast FPU save and restore... done. 
Enabling unmasked SIMD FPU exception support... done. 
Checking 'hlt' instruction... OK. 
Checking for popad bug... OK. 
ACPI: Looking for DSDT in initrd... not found! 
ACPI: setting ELCR to 0200 (from 0800) 
checking if image is initramfs...it isn't (bad gzip magic numbers); looks like an 
Freeing initrd memory: 4248k freed 
NET: Registered protocol family 16 
EISA bus registered 
PCI: PCI BIOS revision 2.10 entry at 0xed8e3, last bus=1 
PCI: Using configuration type 1 
mtrr: v2.0 (20020519) 
ACPI: Subsystem revision 20050211 
ACPI: Interpreter enabled 
ACPI: Using PIC for interrupt routing 
ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 6 7 10 11) *0, disabled. 
ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 6 7 10 11) *0, disabled. 
ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 5 6 7 10 *11) 
ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 5 6 7 10 *11) 
ACPI: PCI Root Bridge [PCI0] (00:00) 
PCI: Probing PCI hardware (bus 00) 
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT] 
Linux Plug and Play Support v0.97 (c) Adam Belay 
pnp: PnP ACPI init 
pnp: PnP ACPI: found 14 devices 
PnPBIOS: Disabled by ACPI PNP 
PCI: Using ACPI for IRQ routing 
** PCI interrupts are no longer routed automatically.  If this 
** causes a device to stop working, it is probably because the 
** driver failed to call pci_enable_device().  As a temporary 
** workaround, the "pci=routeirq" argument restores the old 
** behavior.  If this argument makes the device work again, 
** please email the output of "lspci" to bjorn.helgaas at hp.com 
** so I can fix the driver. 
pnp: 00:0b: ioport range 0x15c-0x15d has been reserved 
pnp: 00:0b: ioport range 0x4d0-0x4d1 has been reserved 
pnp: 00:0c: ioport range 0xf800-0xf81f could not be reserved 
pnp: 00:0c: ioport range 0xf820-0xf83f has been reserved 
pnp: 00:0c: ioport range 0xfc00-0xfc0f has been reserved 
audit: initializing netlink socket (disabled) 
audit(1122306635.623:0): initialized 
VFS: Disk quotas dquot_6.5.1 
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes) 
devfs: 2004-01-31 Richard Gooch (rgooch at atnf.csiro.au) 
devfs: boot_options: 0x0 
Initializing Cryptographic API 
Limiting direct PCI/PCI transfers. 
isapnp: Scanning for PnP cards... 
isapnp: No Plug & Play device found 
serio: i8042 AUX port at 0x60,0x64 irq 12 
serio: i8042 KBD port at 0x60,0x64 irq 1 
Serial: 8250/16550 driver $Revision: 1.90 $ 54 ports, IRQ sharing enabled 
ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A 
ttyS1 at I/O 0x2f8 (irq = 3) is a NS16550A 
ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A 
ttyS1 at I/O 0x2f8 (irq = 3) is a NS16550A 
io scheduler noop registered 
io scheduler anticipatory registered 
io scheduler deadline registered 
io scheduler cfq registered 
RAMDISK driver initialized: 16 RAM disks of 8192K size 1024 blocksize 
input: AT Translated Set 2 keyboard on isa0060/serio0 
EISA: Probing bus 0 at eisa0 
Cannot allocate resource for EISA slot 1 
Cannot allocate resource for EISA slot 2 
EISA: Detected 0 cards. 
NET: Registered protocol family 2 
IP: routing cache hash table of 2048 buckets, 16Kbytes 
TCP: Hash tables configured (established 16384 bind 32768) 
NET: Registered protocol family 8 
NET: Registered protocol family 20 
Restarting tasks...<6> Strange, kswapd0 not stopped 
 Strange, kseriod not stopped 
ACPI wakeup devices: 
ACPI: (supports S0 S1 S4 S5) 
RAMDISK: cramfs filesystem found at block 0 
RAMDISK: Loading 4248KiB [1 disk] into ram disk... done. 
VFS: Mounted root (cramfs filesystem) readonly. 
Freeing unused kernel memory: 224k freed 
ACPI: CPU0 (power states: C1[C1] C2[C2]) 
ACPI: Processor [CPU0] (supports 8 throttling states) 
NET: Registered protocol family 1 
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2 
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx 
PIIX4: IDE controller at PCI slot 0000:00:14.1 
PIIX4: chipset revision 1 
PIIX4: not 100% native mode: will probe irqs later 
    ide0: BM-DMA at 0x2040-0x2047, BIOS settings: hda:DMA, hdb:pio 
    ide1: BM-DMA at 0x2048-0x204f, BIOS settings: hdc:DMA, hdd:pio 
Probing IDE interface ide0... 
hda: ST320420A, ATA DISK drive 
elevator: using anticipatory as default io scheduler 
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14 
hda: max request size: 128KiB 
hda: 39851760 sectors (20404 MB) w/2048KiB Cache, CHS=39535/16/63, UDMA(33) 
hda: cache flushes not supported 
 /dev/ide/host0/bus0/target0/lun0: p1 p2 p3 < p5 > 
Probing IDE interface ide1... 
hdc: Compaq CRN-8241B, ATAPI CD/DVD-ROM drive 
ide1 at 0x170-0x177,0x376 on irq 15 
Probing IDE interface ide2... 
Probing IDE interface ide3... 
Probing IDE interface ide4... 
Probing IDE interface ide5... 
Stopping tasks: ==| 
Freeing memory... done (455 pages freed) 
Restarting tasks... done 
EXT3-fs: mounted filesystem with ordered data mode. 
kjournald starting.  Commit interval 5 seconds 
Adding 1028120k swap on /dev/hda1.  Priority:-1 extents:1 
EXT3 FS on hda2, internal journal 
hdc: ATAPI 24X CD-ROM drive, 128kB Cache 
Uniform CD-ROM driver Revision: 3.20 
parport: PnPBIOS parport detected. 
parport0: PC-style at 0x378 (0x778), irq 7, dma 3 [PCSPP,TRISTATE,COMPAT,EPP,ECP,DMA] 
parport0: Printer, HEWLETT-PACKARD DESKJET 690C 
lp0: using parport0 (interrupt-driven). 
mice: PS/2 mouse device common for all mice 
input: ImExPS/2 Generic Explorer Mouse on isa0060/serio1 
ts: Compaq touchscreen protocol output 
Capability LSM initialized 
device-mapper: 4.3.0-ioctl (2004-09-30) initialised: dm-devel at redhat.com 
md: md driver 0.90.1 MAX_MD_DEVS=256, MD_SB_DISKS=27 
hdc: packet command error: status=0x51 { DriveReady SeekComplete Error } 
hdc: packet command error: error=0x54 
ide: failed opcode was 100 
cdrom: open failed. 
Real Time Clock Driver v1.12 
input: PC Speaker 
inserting floppy driver for 2.6.10-5-386 
Floppy drive(s): fd0 is 1.44M 
FDC 0 is a National Semiconductor PC87306 
Linux agpgart interface v0.100 (c) Dave Jones 
agpgart: Detected an Intel 440BX Chipset. 
agpgart: Maximum main memory to use for agp memory: 204M 
agpgart: AGP aperture is 64M @ 0x44000000 
cpci_hotplug: CompactPCI Hot Plug Core version: 0.2 
pci_hotplug: PCI Hot Plug PCI Core version: 0.5 
shpchp: acpi_shpchprm:\_SB_.PCI0 evaluate _BBN fail=0x5 
shpchp: acpi_shpchprm:get_device PCI ROOT HID fail=0x5 
pciehp: acpi_pciehprm:\_SB_.PCI0 evaluate _BBN fail=0x5 
pciehp: acpi_pciehprm:get_device PCI ROOT HID fail=0x5 
e100: Intel(R) PRO/100 Network Driver, 3.2.3-k2-NAPI 
e100: Copyright(c) 1999-2004 Intel Corporation 
ACPI: PCI Interrupt Link [LNKD] enabled at IRQ 11 
PCI: setting IRQ 11 as level-triggered 
ACPI: PCI interrupt 0000:00:0a.0[A] -> GSI 11 (level, low) -> IRQ 11 
e100: eth0: e100_probe: addr 0x42000000, irq 11, MAC addr 00:50:8B:FB:03:1F 
e100: eth0: e100_watchdog: link up, 100Mbps, full-duplex 
usbcore: registered new driver usbfs 
usbcore: registered new driver hub 
USB Universal Host Controller Interface driver v2.2 
ACPI: PCI interrupt 0000:00:14.2[D] -> GSI 11 (level, low) -> IRQ 11 
uhci_hcd 0000:00:14.2: Intel Corp. 82371AB/EB/MB PIIX4 USB 
uhci_hcd 0000:00:14.2: irq 11, io base 0x2020 
uhci_hcd 0000:00:14.2: new USB bus registered, assigned bus number 1 
hub 1-0:1.0: USB hub found 
hub 1-0:1.0: 2 ports detected 
NET: Registered protocol family 17 
usb 1-2: new full speed USB device using uhci_hcd and address 2 
hub 1-2:1.0: USB hub found 
hub 1-2:1.0: 4 ports detected 
piix4_smbus 0000:00:14.3: Found 0000:00:14.3 device 
NET: Registered protocol family 10 
Disabled Privacy Extensions on device c02f0500(lo) 
IPv6 over IPv4 tunneling driver 
vga16fb: initializing 
vga16fb: mapped to 0xc00a0000 
Console: switching to colour frame buffer device 80x30 
fb0: VGA16 VGA frame buffer device 
eth0: no IPv6 routers present 
ACPI: Power Button (CM) [PBTN] 
ibm_acpi: ec object not found 
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16ac) 
apm: overridden by ACPI. 
ibm_acpi: ec object not found 
lp0: ECP mode 
lp0: ECP mode 
lp0: ECP mode 
lp0: ECP mode 
lp0: ECP mode 
lp0: ECP mode 
lp0: ECP mode 
lp0: ECP mode 
lp0: ECP mode 
ESS AudioDrive ES18xx soundcard not found or device busy 
ESS AudioDrive ES18xx soundcard not found or device busy 
ESS AudioDrive ES18xx soundcard not found or device busy 
ESS AudioDrive ES18xx soundcard not found or device busy 
ESS AudioDrive ES18xx soundcard not found or device busy 
ESS AudioDrive ES18xx soundcard not found or device busy 
Sound Blaster 16 soundcard not found or device busy 
In case, if you have AWE card, try snd-sbawe module 
ESS AudioDrive ES18xx soundcard not found or device busy 
My lsmod : 
# lsmod 
Module                  Size  Used by 
snd_sb16_dsp           10496  0 
snd_sb16_csp           19072  0 
snd_sb_common          14848  2 snd_sb16_dsp,snd_sb16_csp 
snd_seq_midi            8224  0 
snd_seq_oss            30080  0 
snd_seq_midi_event      7424  2 snd_seq_midi,snd_seq_oss 
snd_seq                46992  5 snd_seq_midi,snd_seq_oss,snd_seq_midi_event 
snd_opl3_lib           10112  0 
snd_hwdep               9220  2 snd_sb16_csp,snd_opl3_lib 
snd_mpu401_uart         7168  0 
snd_rawmidi            22944  2 snd_seq_midi,snd_mpu401_uart 
snd_seq_device          8332  5 
snd_pcm_oss            47652  0 
snd_pcm                84872  2 snd_sb16_dsp,snd_pcm_oss 
snd_timer              23300  3 snd_seq,snd_opl3_lib,snd_pcm 
snd_page_alloc          9604  1 snd_pcm 
snd_mixer_oss          16768  1 snd_pcm_oss 
snd                    50276  14 
soundcore               9824  1 snd 
speedstep_lib           4228  0 
proc_intf               4100  0 
freq_table              4100  0 
cpufreq_userspace       4572  0 
cpufreq_ondemand        6172  0 
cpufreq_powersave       1920  0 
video                  16260  0 
sony_acpi               6280  0 
pcc_acpi               11264  0 
button                  6800  0 
battery                10244  0 
container               4608  0 
ac                      4996  0 
vga16fb                12488  1 
vgastate                8576  1 vga16fb 
ipv6                  229504  9 
i2c_piix4               8592  0 
i2c_core               21264  1 i2c_piix4 
af_packet              20744  2 
uhci_hcd               30224  0 
usbcore               107384  2 uhci_hcd 
e100                   32384  0 
mii                     4736  1 e100 
pci_hotplug            30512  0 
intel_agp              20636  1 
agpgart                31784  1 intel_agp 
floppy                 54864  0 
pcspkr                  3816  0 
rtc                    12216  0 
nls_iso8859_1           4224  1 
nls_cp437               5888  1 
vfat                   12928  1 
fat                    37792  1 vfat 
md                     43856  0 
dm_mod                 53116  1 
evdev                   9088  0 
capability              5000  0 
tsdev                   7488  0 
commoncap               7808  1 capability 
psmouse                19336  0 
mousedev               11160  1 
parport_pc             34372  1 
lp                     10792  0 
parport                33480  2 parport_pc,lp 
ide_cd                 38532  1 
cdrom                  36508  1 ide_cd 
ext3                  120968  1 
jbd                    54168  1 ext3 
ide_generic             1664  0 
piix                    9988  1 
ide_disk               18176  4 
ide_core              118988  4 ide_cd,ide_generic,piix,ide_disk 
unix                   26164  528 
thermal                13576  0 
processor              22708  1 thermal 
fan                     4612  0 
fbcon                  34048  71 
font                    8448  1 fbcon 
bitblit                 5120  1 fbcon 
vesafb                  6948  0 
cfbcopyarea             3968  2 vga16fb,vesafb 
cfbimgblt               3072  2 vga16fb,vesafb 
cfbfillrect             3584  2 vga16fb,vesafb 
My modinfo snd-es18xx : 
# modinfo snd-es18xx 
filename:       /lib/modules/2.6.10-5-386/kernel/sound/isa/snd-es18xx.ko 
author:         Christian Fischbach <fishbach at pool.informatik.rwth-aachen.de>, Abramo 
Bagnara <abramo at alsa-project.org> 
description:    ESS ES18xx AudioDrive 
license:        GPL 
parm:           index:Index value for ES18xx soundcard. 
parm:           id:ID string for ES18xx soundcard. 
parm:           enable:Enable ES18xx soundcard. 
parm:           isapnp:PnP detection for specified soundcard. 
parm:           port:Port # for ES18xx driver. 
parm:           mpu_port:MPU-401 port # for ES18xx driver. 
parm:           fm_port:FM port # for ES18xx driver. 
parm:           irq:IRQ # for ES18xx driver. 
parm:           dma1:DMA 1 # for ES18xx driver. 
parm:           dma2:DMA 2 # for ES18xx driver. 
vermagic:       2.6.10-5-386 preempt 386 gcc-3.3 
depends:        snd-pcm,snd,snd-opl3-lib,snd-mpu401-uart 
alias:          pnp:cESS1868dESS1868dESS0000* 
alias:          pnp:cESS1868dESS8601dESS8600* 
alias:          pnp:cESS1868dESS8611dESS8610* 
alias:          pnp:cESS0003dESS1869dESS0006* 
alias:          pnp:cESS1869dESS1869dESS0006* 
alias:          pnp:cESS1878dESS1878dESS0004* 
alias:          pnp:cESS1879dESS1879dESS0009* 
srcversion:     2A7952BB92B73FC3A09BEC9 
My partial /etc/modprobe.d/alias : 
# character devices ########################################################## 
alias char-major-9 st 
install char-major-10 /bin/true 
alias char-major-81 videodev 
My partial /etc/modprobe.d/alsa-base : 
# autoloader aliases 
alias char-major-116 snd 
alias char-major-14 soundcore 
install sound-service-0-0 modprobe snd-card-0 snd-mixer-oss 
install sound-service-0-1 modprobe snd-card-0 snd-seq-oss 
install sound-service-0-3 modprobe snd-card-0 snd-pcm-oss 
install sound-service-0-8 modprobe snd-card-0 snd-seq-oss 
install sound-service-0-12 modprobe snd-card-0 snd-pcm-oss 
install sound-slot-0 modprobe snd-card-0 
install sound-slot-1 modprobe snd-card-1 
install sound-slot-2 modprobe snd-card-2 
install sound-slot-3 modprobe snd-card-3 
install sound-slot-4 modprobe snd-card-4 
install sound-slot-5 modprobe snd-card-5 
install sound-slot-6 modprobe snd-card-6 
install sound-slot-7 modprobe snd-card-7 
# Load optional modules above their base modules 
install snd-pcm modprobe --ignore-install snd-pcm && { modprobe snd-pcm-oss ; : ; } 
install snd-mixer modprobe --ignore-install snd-mixer && { modprobe 
snd-mixer-oss ; : ; } 
install snd-seq modprobe --ignore-install snd-seq && { modprobe snd-seq-oss ; modprobe 
snd-seq-midi ; : ; } 
# Cause a script to be run after snd-emu8000-synth module initialization 
install snd-emu8000-synth modprobe --ignore-install snd-emu8000-synth 
&& /lib/alsa/modprobe-post-install snd-emu8000-synth 
# Cause a script to be run after card driver module initialization 
install snd-es18xx modprobe --ignore-install snd-es18xx 
&& /lib/alsa/modprobe-post-install snd-es18xx 
My /etc/modutils seems to contains the same alsa-base file 
No /etc/modules.conf exist.

Configure bugmail: http://bugzilla.ubuntu.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug, or are watching the QA contact.

More information about the kubuntu-bugs mailing list